summaryrefslogtreecommitdiffstats
path: root/python/pipdeptree/pipdeptree.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pipdeptree/pipdeptree.SlackBuild')
-rw-r--r--python/pipdeptree/pipdeptree.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/pipdeptree/pipdeptree.SlackBuild b/python/pipdeptree/pipdeptree.SlackBuild
index e93d7b7fad..65bd28eeb4 100644
--- a/python/pipdeptree/pipdeptree.SlackBuild
+++ b/python/pipdeptree/pipdeptree.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pipdeptree
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pipdeptree
-VERSION=${VERSION:-0.11.0}
+VERSION=${VERSION:-2.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true