summaryrefslogtreecommitdiffstats
path: root/python/pip/pip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pip/pip.SlackBuild')
-rw-r--r--python/pip/pip.SlackBuild25
1 files changed, 22 insertions, 3 deletions
diff --git a/python/pip/pip.SlackBuild b/python/pip/pip.SlackBuild
index 40ab020062..fd82982b62 100644
--- a/python/pip/pip.SlackBuild
+++ b/python/pip/pip.SlackBuild
@@ -1,10 +1,29 @@
#!/bin/sh
# Slackware build script for pip
-# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+
+# Copyright 2012 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pip
-VERSION=${VERSION:-1.0.2}
+VERSION=${VERSION:-1.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,7 +58,7 @@ find . \
python setup.py install --root=$PKG
# Add bash completion file.
-install -D -m 644 $CWD/pip.sh $PKG/etc/bash_completion.d/pip
+install -D -m 644 $CWD/pip.sh $PKG/usr/share/bash-completion/completions/pip
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.txt docs/* $PKG/usr/doc/$PRGNAM-$VERSION