summaryrefslogtreecommitdiffstats
path: root/python/pelican/pelican.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pelican/pelican.SlackBuild')
-rw-r--r--python/pelican/pelican.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/python/pelican/pelican.SlackBuild b/python/pelican/pelican.SlackBuild
index 1d6d34fba4..dbfceb7e83 100644
--- a/python/pelican/pelican.SlackBuild
+++ b/python/pelican/pelican.SlackBuild
@@ -2,15 +2,17 @@
# Slackware build script for pelican
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2015-2019 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
+#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
@@ -20,13 +22,13 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+
+# 20221011 46and2: Updated version, new maintainer.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pelican
-VERSION=${VERSION:-4.2.0}
+VERSION=${VERSION:-4.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,13 +82,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs/* pelican/themes/ LICENSE README.rst THANKS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a pelican/themes/ LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install