summaryrefslogtreecommitdiffstats
path: root/python/nyx/nyx.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/nyx/nyx.SlackBuild')
-rw-r--r--python/nyx/nyx.SlackBuild35
1 files changed, 7 insertions, 28 deletions
diff --git a/python/nyx/nyx.SlackBuild b/python/nyx/nyx.SlackBuild
index 15cc7c3e00..b6fe1d81df 100644
--- a/python/nyx/nyx.SlackBuild
+++ b/python/nyx/nyx.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for nyx
-# Copyright 2017-2019 Markus Reichelt, Aachen, DE
+# Copyright 2017-2023 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,12 +22,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+# 20230526 bkw: modified slightly by SlackBuilds.org
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=nyx
VERSION=${VERSION:-2.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,22 +60,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/man/man1
cp -a web/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a nyx.1 $PKG/usr/man/man1
+gzip -9c < nyx.1 > $PKG/usr/man/man1/nyx.1.gz
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc