summaryrefslogtreecommitdiffstats
path: root/python/numexpr/numexpr.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/numexpr/numexpr.SlackBuild')
-rw-r--r--python/numexpr/numexpr.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/numexpr/numexpr.SlackBuild b/python/numexpr/numexpr.SlackBuild
index 50658ec807..3a3b071cca 100644
--- a/python/numexpr/numexpr.SlackBuild
+++ b/python/numexpr/numexpr.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for numexpr
-# Copyright 2010-2013 LukenShiro, Italy
+# Copyright 2010-2014 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=numexpr
-VERSION=${VERSION:-2.2.2}
+VERSION=${VERSION:-2.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -54,7 +54,7 @@ else
LIBDIRSUFFIX=""
fi
-DOCFILES="ANNOUNCE.txt INSTALL.txt LICENSE.txt README.txt RELEASE_NOTES.txt"
+DOCFILES="ANNOUNCE.rst README.rst AUTHORS.txt INSTALL.rst RELEASE_NOTES.rst"
set -e
@@ -66,10 +66,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build install --root=$PKG