summaryrefslogtreecommitdiffstats
path: root/python/npm
diff options
context:
space:
mode:
Diffstat (limited to 'python/npm')
-rw-r--r--python/npm/npm.SlackBuild13
-rw-r--r--python/npm/npm.info2
2 files changed, 4 insertions, 11 deletions
diff --git a/python/npm/npm.SlackBuild b/python/npm/npm.SlackBuild
index b4d412ccd0..29ae80e9e4 100644
--- a/python/npm/npm.SlackBuild
+++ b/python/npm/npm.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -73,12 +70,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
diff --git a/python/npm/npm.info b/python/npm/npm.info
index e1733cc4e7..d1e9ec09e2 100644
--- a/python/npm/npm.info
+++ b/python/npm/npm.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/ca/4d/7d59d82b777f3f7a11286081
MD5SUM="c87635e753df39cd4a6bf626bd6e2956"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="optional-django nose"
+REQUIRES="optional-django"
MAINTAINER="Pr. HORSTMANN"
EMAIL="wmh@eipg.fr"