summaryrefslogtreecommitdiffstats
path: root/python/netifaces/netifaces.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/netifaces/netifaces.SlackBuild')
-rw-r--r--python/netifaces/netifaces.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
index 60acb41e48..0e9626f9bf 100644
--- a/python/netifaces/netifaces.SlackBuild
+++ b/python/netifaces/netifaces.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for netifaces
-# Copyright 2012-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=netifaces
-VERSION=${VERSION:-0.10.5}
+VERSION=${VERSION:-0.10.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,6 +57,10 @@ find -L . \
python setup.py install --root=$PKG
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true