summaryrefslogtreecommitdiffstats
path: root/python/ipython/ipython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/ipython/ipython.SlackBuild')
-rw-r--r--python/ipython/ipython.SlackBuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/python/ipython/ipython.SlackBuild b/python/ipython/ipython.SlackBuild
index ad5058cba7..34e9d4063d 100644
--- a/python/ipython/ipython.SlackBuild
+++ b/python/ipython/ipython.SlackBuild
@@ -3,6 +3,7 @@
# SlackBuild for IPython
# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# Copyright 2013-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Maintained by Benjamin-Trigona-Harany
-
PRGNAM=ipython
-VERSION=${VERSION:-5.6.0}
+VERSION=${VERSION:-5.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -51,15 +50,17 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-
+chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root="$PKG"
-rm $PKG/usr/bin/ipython2
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
@@ -69,8 +70,9 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
rm -rf $PKG/usr/share
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
-cp COPYING.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp \
+ COPYING.rst README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install