summaryrefslogtreecommitdiffstats
path: root/python/httplib2
diff options
context:
space:
mode:
Diffstat (limited to 'python/httplib2')
-rw-r--r--python/httplib2/README2
-rw-r--r--python/httplib2/httplib2.SlackBuild108
-rw-r--r--python/httplib2/httplib2.info10
-rw-r--r--python/httplib2/slack-desc19
-rw-r--r--python/httplib2/use_system_cacerts.patch56
5 files changed, 0 insertions, 195 deletions
diff --git a/python/httplib2/README b/python/httplib2/README
deleted file mode 100644
index 4303c42043..0000000000
--- a/python/httplib2/README
+++ /dev/null
@@ -1,2 +0,0 @@
-A comprehensive HTTP client library that supports many features
-left out of other HTTP libraries.
diff --git a/python/httplib2/httplib2.SlackBuild b/python/httplib2/httplib2.SlackBuild
deleted file mode 100644
index 79cdb49771..0000000000
--- a/python/httplib2/httplib2.SlackBuild
+++ /dev/null
@@ -1,108 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for httplib2
-
-# Copyright 2013-2019 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=httplib2
-VERSION=${VERSION:-0.11.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-DOCS="CHANGELOG LICENSE README.md"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION $PRGNAM-$VERSION-2
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Use system ca-certificates.crt.
-patch -p1 < $CWD/use_system_cacerts.patch
-
-cp -a ../$PRGNAM-$VERSION ../$PRGNAM-$VERSION-2
-
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- ( cd ../$PRGNAM-$VERSION-2
- sed -i "s|raise socket\.error, msg|raise socket_err|" python*/httplib2/__init__.py || exit 1
- python3 setup.py install --root=$PKG )
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/httplib2/httplib2.info b/python/httplib2/httplib2.info
deleted file mode 100644
index 57138aacca..0000000000
--- a/python/httplib2/httplib2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="httplib2"
-VERSION="0.11.3"
-HOMEPAGE="https://github.com/httplib2/httplib2/"
-DOWNLOAD="https://github.com/httplib2/httplib2/archive/v0.11.3/httplib2-0.11.3.tar.gz"
-MD5SUM="b5dba454b541087cc5f674fed74916b4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Matteo Bernardini"
-EMAIL="ponce@slackbuilds.org"
diff --git a/python/httplib2/slack-desc b/python/httplib2/slack-desc
deleted file mode 100644
index a0afc2576a..0000000000
--- a/python/httplib2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-httplib2: httplib2 (python http library)
-httplib2:
-httplib2: A comprehensive HTTP client library that supports many features
-httplib2: left out of other HTTP libraries.
-httplib2:
-httplib2: homepage: https://github.com/httplib2/httplib2/
-httplib2:
-httplib2:
-httplib2:
-httplib2:
-httplib2:
diff --git a/python/httplib2/use_system_cacerts.patch b/python/httplib2/use_system_cacerts.patch
deleted file mode 100644
index 7f58da2992..0000000000
--- a/python/httplib2/use_system_cacerts.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From: Marc Deslauriers <marc.deslauriers@canonical.com>
-Date: Wed, 5 Sep 2018 14:02:17 +0800
-Subject: Use system ca certificates, not the bundled ones
-
-Forwarded: not-needed
-Bug-Ubuntu: https://launchpad.net/bugs/882027
----
- python2/httplib2/__init__.py | 5 ++---
- python3/httplib2/__init__.py | 5 ++---
- setup.py | 1 -
- 3 files changed, 4 insertions(+), 7 deletions(-)
-
-diff --git a/python2/httplib2/__init__.py b/python2/httplib2/__init__.py
-index 18b013d..8b9a8c0 100644
---- a/python2/httplib2/__init__.py
-+++ b/python2/httplib2/__init__.py
-@@ -217,9 +217,8 @@ try:
- import ca_certs_locater
- CA_CERTS = ca_certs_locater.get()
- except ImportError:
-- # Default CA certificates file bundled with httplib2.
-- CA_CERTS = os.path.join(
-- os.path.dirname(os.path.abspath(__file__ )), "cacerts.txt")
-+ # Use system CA certificates
-+ CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
-
- # Which headers are hop-by-hop headers by default
- HOP_BY_HOP = ['connection', 'keep-alive', 'proxy-authenticate', 'proxy-authorization', 'te', 'trailers', 'transfer-encoding', 'upgrade']
-diff --git a/python3/httplib2/__init__.py b/python3/httplib2/__init__.py
-index 5dae2a5..8c63925 100644
---- a/python3/httplib2/__init__.py
-+++ b/python3/httplib2/__init__.py
-@@ -124,9 +124,8 @@ DEFAULT_MAX_REDIRECTS = 5
- # Which headers are hop-by-hop headers by default
- HOP_BY_HOP = ['connection', 'keep-alive', 'proxy-authenticate', 'proxy-authorization', 'te', 'trailers', 'transfer-encoding', 'upgrade']
-
--# Default CA certificates file bundled with httplib2.
--CA_CERTS = os.path.join(
-- os.path.dirname(os.path.abspath(__file__ )), "cacerts.txt")
-+# Use system CA certificates
-+CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
-
- # PROTOCOL_TLS is python 3.5.3+. PROTOCOL_SSLv23 is deprecated.
- # Both PROTOCOL_TLS and PROTOCOL_SSLv23 are equivalent and means:
-diff --git a/setup.py b/setup.py
-index 0f3a516..9c07bc2 100755
---- a/setup.py
-+++ b/setup.py
-@@ -58,7 +58,6 @@ A comprehensive HTTP client library, ``httplib2`` supports many features left ou
- """,
- package_dir=pkgdir,
- packages=['httplib2'],
-- package_data={'httplib2': ['*.txt']},
- classifiers=(
- 'Development Status :: 4 - Beta',
- 'Environment :: Web Environment',