summaryrefslogtreecommitdiffstats
path: root/python/httplib2/httplib2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/httplib2/httplib2.SlackBuild')
-rw-r--r--python/httplib2/httplib2.SlackBuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/python/httplib2/httplib2.SlackBuild b/python/httplib2/httplib2.SlackBuild
index c4fc145f20..d9e910a83c 100644
--- a/python/httplib2/httplib2.SlackBuild
+++ b/python/httplib2/httplib2.SlackBuild
@@ -23,7 +23,7 @@
PRGNAM=httplib2
VERSION=${VERSION:-0.8}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -53,9 +53,12 @@ else
LIBDIRSUFFIX=""
fi
+PYTHON=python
+[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
+
DOCS="CHANGELOG README"
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -70,7 +73,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+# Fix ssl hostname mismatch.
+patch -p1 < $CWD/ssl_hostname.diff
+# Use system ca-certificates.crt.
+patch -p1 < $CWD/use_system_cacerts.patch
+
+$PYTHON setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true