summaryrefslogtreecommitdiffstats
path: root/python/git-fame
diff options
context:
space:
mode:
Diffstat (limited to 'python/git-fame')
-rw-r--r--python/git-fame/git-fame.SlackBuild10
-rw-r--r--python/git-fame/git-fame.info8
2 files changed, 8 insertions, 10 deletions
diff --git a/python/git-fame/git-fame.SlackBuild b/python/git-fame/git-fame.SlackBuild
index 076708a375..fd4685bdd6 100644
--- a/python/git-fame/git-fame.SlackBuild
+++ b/python/git-fame/git-fame.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for git-fame
# Copyright 2017-2021 Andrew Clemons, Wellington New Zealand
+# Copyright 2022-2023 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=git-fame
-VERSION=${VERSION:-1.15.1}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.0.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +77,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/git-fame/git-fame.info b/python/git-fame/git-fame.info
index b4f9198285..fc1dfdb759 100644
--- a/python/git-fame/git-fame.info
+++ b/python/git-fame/git-fame.info
@@ -1,10 +1,10 @@
PRGNAM="git-fame"
-VERSION="1.15.1"
+VERSION="2.0.1"
HOMEPAGE="https://pypi.python.org/pypi/git-fame"
-DOWNLOAD="https://files.pythonhosted.org/packages/59/83/5820a5f114822a23e56cdd60e156ba52822d4430b37ba3f68b2a800d56ee/git-fame-1.15.1.tar.gz"
-MD5SUM="7155db82b6addc8d9c4f91d8533d3e24"
+DOWNLOAD="https://files.pythonhosted.org/packages/7a/f2/fd903eafd3bf5d5dff0d5885a9fd9f25d3779968897e61d406c57ed0aaf9/git-fame-2.0.1.tar.gz"
+MD5SUM="b8b0be30c8b6bdcf5f9d23d61f03d676"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-argopt docopt tqdm python2-tabulate"
+REQUIRES="python-argopt python3-docopt tqdm python3-tabulate"
MAINTAINER="Andrew Clemons"
EMAIL="andrew.clemons@gmail.com"