summaryrefslogtreecommitdiffstats
path: root/python/flake8
diff options
context:
space:
mode:
Diffstat (limited to 'python/flake8')
-rw-r--r--python/flake8/flake8.SlackBuild11
-rw-r--r--python/flake8/flake8.info10
2 files changed, 9 insertions, 12 deletions
diff --git a/python/flake8/flake8.SlackBuild b/python/flake8/flake8.SlackBuild
index e5593b72c1..2c731b46d3 100644
--- a/python/flake8/flake8.SlackBuild
+++ b/python/flake8/flake8.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for flake8
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=flake8
-VERSION=${VERSION:-3.5.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-7.0.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,10 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Ignores setuptools version, it works for me
-sed -i "s/setuptools >= 30\",/\"/" setup.py
-
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/flake8/flake8.info b/python/flake8/flake8.info
index 43bae520af..6fc8a878cb 100644
--- a/python/flake8/flake8.info
+++ b/python/flake8/flake8.info
@@ -1,10 +1,10 @@
PRGNAM="flake8"
-VERSION="3.5.0"
+VERSION="7.0.0"
HOMEPAGE="https://gitlab.com/pycqa/flake8"
-DOWNLOAD="https://pypi.python.org/packages/1e/ab/7730f6d6cdf73a3b7f98a2fe3b2cdf68e9e760a4a133e083607497d4c3a6/flake8-3.5.0.tar.gz"
-MD5SUM="7e5fe39d578a2c2d0962b61b35b8c3fc"
+DOWNLOAD="https://files.pythonhosted.org/packages/40/3c/3464b567aa367b221fa610bbbcce8015bf953977d21e52f2d711b526fb48/flake8-7.0.0.tar.gz"
+MD5SUM="0e698aff81684bc1c13994a3f6a3bc6a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python2-pytest-runner pycodestyle pyflakes python2-mccabe ConfigParser"
+REQUIRES="pycodestyle python3-pyflakes python3-mccabe"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"