summaryrefslogtreecommitdiffstats
path: root/python/filechunkio/filechunkio.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/filechunkio/filechunkio.SlackBuild')
-rw-r--r--python/filechunkio/filechunkio.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/filechunkio/filechunkio.SlackBuild b/python/filechunkio/filechunkio.SlackBuild
index 2f9be5dea5..6cc92f40db 100644
--- a/python/filechunkio/filechunkio.SlackBuild
+++ b/python/filechunkio/filechunkio.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for filechunkio
-# Copyright 2011-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=filechunkio
-VERSION=${VERSION:-1.6}
+VERSION=${VERSION:-1.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,6 +59,7 @@ python setup.py install --root=$PKG
# Install python3 modules. Default is no.
if [ "${PYTHON3:-no}" == "yes" ]; then
+ rm -rf build
python3 setup.py install --root=$PKG
fi
@@ -66,7 +67,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install