summaryrefslogtreecommitdiffstats
path: root/python/feedparser/feedparser.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/feedparser/feedparser.SlackBuild')
-rw-r--r--python/feedparser/feedparser.SlackBuild21
1 files changed, 4 insertions, 17 deletions
diff --git a/python/feedparser/feedparser.SlackBuild b/python/feedparser/feedparser.SlackBuild
index d777317ae2..1743c87784 100644
--- a/python/feedparser/feedparser.SlackBuild
+++ b/python/feedparser/feedparser.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for feedparser
# Modified by Luis Henrique <lmello.009@gmail.com>
-# Maintained 2014-2019 by Christoph Willing <chris.willing@linux.com>
+# Maintained 2014-2021 by Christoph Willing <chris.willing@linux.com>
# Copyright 2008-2009 Chess Griffin <chess@chessgriffin.com>
# All rights reserved.
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=feedparser
-VERSION=${VERSION:-5.2.1}
+VERSION=${VERSION:-6.0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,21 +83,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build
-python setup.py install --root $PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- # Python3 doesn't have sgmllib so we provide it here for building
- # and later installation as part of the feedparser package.
- cp feedparser/sgmllib3.py feedparser/sgmllib.py
- PYTHONPATH=$(pwd)/feedparser:$PYTHONPATH
-
- patch -p0 < $CWD/001_py37.diff
- python3 setup.py build
- python3 setup.py install --root $PKG
-
- PYSITEDIR=$(python3 -c "import site; print(site.getsitepackages()[0])")
- install -m 0644 feedparser/sgmllib.py $PKG/$PYSITEDIR
-fi
+python3 setup.py build
+python3 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true