summaryrefslogtreecommitdiffstats
path: root/python/dnspython/dnspython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/dnspython/dnspython.SlackBuild')
-rw-r--r--python/dnspython/dnspython.SlackBuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/python/dnspython/dnspython.SlackBuild b/python/dnspython/dnspython.SlackBuild
index d5df6ee9e4..65c379b04e 100644
--- a/python/dnspython/dnspython.SlackBuild
+++ b/python/dnspython/dnspython.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for dnspython
-# Copyright 2009-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2019 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dnspython
-VERSION=${VERSION:-1.15.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.16.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -50,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -61,11 +61,11 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install