summaryrefslogtreecommitdiffstats
path: root/python/cppy/cppy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/cppy/cppy.SlackBuild')
-rw-r--r--python/cppy/cppy.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/python/cppy/cppy.SlackBuild b/python/cppy/cppy.SlackBuild
index 342f26f47b..db7be8704a 100644
--- a/python/cppy/cppy.SlackBuild
+++ b/python/cppy/cppy.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for cppy
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cppy
-VERSION=${VERSION:-1.2.0}
+VERSION=${VERSION:-1.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,16 +40,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
@@ -66,6 +64,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
python3 setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \