summaryrefslogtreecommitdiffstats
path: root/python/colorama/colorama.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/colorama/colorama.SlackBuild')
-rw-r--r--python/colorama/colorama.SlackBuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/python/colorama/colorama.SlackBuild b/python/colorama/colorama.SlackBuild
index 7676d072cb..a9a5720161 100644
--- a/python/colorama/colorama.SlackBuild
+++ b/python/colorama/colorama.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for colorama
-# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=colorama
-VERSION=${VERSION:-0.4.4}
+VERSION=${VERSION:-0.4.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,12 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true