summaryrefslogtreecommitdiffstats
path: root/python/click-repl
diff options
context:
space:
mode:
Diffstat (limited to 'python/click-repl')
-rw-r--r--python/click-repl/README2
-rw-r--r--python/click-repl/click-repl.SlackBuild91
-rw-r--r--python/click-repl/click-repl.info10
-rw-r--r--python/click-repl/slack-desc19
4 files changed, 0 insertions, 122 deletions
diff --git a/python/click-repl/README b/python/click-repl/README
deleted file mode 100644
index 371cc91bd8..0000000000
--- a/python/click-repl/README
+++ /dev/null
@@ -1,2 +0,0 @@
-REPL plugin for Click
-For Python2 and Python3.
diff --git a/python/click-repl/click-repl.SlackBuild b/python/click-repl/click-repl.SlackBuild
deleted file mode 100644
index f47c56d518..0000000000
--- a/python/click-repl/click-repl.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/bash
-
-# SlackBuild build script for click-repl
-
-# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=click-repl
-SRCPKG=${SRCPKG-click-repl}
-VERSION=${VERSION:-0.1.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM="$(printf $SRCPKG | cut -d- -f1-)"
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
-
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/click-repl/click-repl.info b/python/click-repl/click-repl.info
deleted file mode 100644
index f04702a1fa..0000000000
--- a/python/click-repl/click-repl.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="click-repl"
-VERSION="0.1.6"
-HOMEPAGE="https://pypi.org/project/click-repl/"
-DOWNLOAD="https://files.pythonhosted.org/packages/51/99/6a722e232f92fdc21c46fd042fea63e7c2fcda3086ff5db62edd595d3f49/click-repl-0.1.6.tar.gz"
-MD5SUM="2d5f4d42cbd1da9a50a49dff4d6087ca"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Pr. HORSTMANN"
-EMAIL="wmh@eipg.fr"
diff --git a/python/click-repl/slack-desc b/python/click-repl/slack-desc
deleted file mode 100644
index 94d2444884..0000000000
--- a/python/click-repl/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-click-repl: click-repl (REPL plugin for Click)
-click-repl:
-click-repl:
-click-repl:
-click-repl:
-click-repl:
-click-repl: Homepage: https://pypi.org/project/click-repl/
-click-repl:
-click-repl:
-click-repl:
-click-repl: