summaryrefslogtreecommitdiffstats
path: root/python/cairocffi/cairocffi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/cairocffi/cairocffi.SlackBuild')
-rw-r--r--python/cairocffi/cairocffi.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/cairocffi/cairocffi.SlackBuild b/python/cairocffi/cairocffi.SlackBuild
index 079ffc3c8f..ffc08db367 100644
--- a/python/cairocffi/cairocffi.SlackBuild
+++ b/python/cairocffi/cairocffi.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for cairocffi
-# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cairocffi
-VERSION=${VERSION:-0.9.0} # v0.9.0 is the last version that support python2
+VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,14 +80,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install