summaryrefslogtreecommitdiffstats
path: root/python/boto3
diff options
context:
space:
mode:
Diffstat (limited to 'python/boto3')
-rw-r--r--python/boto3/README7
-rw-r--r--python/boto3/boto3.SlackBuild81
-rw-r--r--python/boto3/boto3.info10
-rw-r--r--python/boto3/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/python/boto3/README b/python/boto3/README
deleted file mode 100644
index 04621bbb23..0000000000
--- a/python/boto3/README
+++ /dev/null
@@ -1,7 +0,0 @@
-Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK)
-for Python, which allows Python developers to write software that
-makes use of services like Amazon S3 and Amazon EC2. You can find the
-latest, most up to date, documentation at `Read the Docs`_, including
-a list of services that are supported.
-
-Note: boto3 can be installed alongside boto.
diff --git a/python/boto3/boto3.SlackBuild b/python/boto3/boto3.SlackBuild
deleted file mode 100644
index 0bc450c47c..0000000000
--- a/python/boto3/boto3.SlackBuild
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for boto3
-
-# Copyright 2015-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=boto3
-VERSION=${VERSION:-1.3.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE *.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/boto3/boto3.info b/python/boto3/boto3.info
deleted file mode 100644
index 7135c77fdb..0000000000
--- a/python/boto3/boto3.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="boto3"
-VERSION="1.3.1"
-HOMEPAGE="https://aws.amazon.com/sdk-for-python/"
-DOWNLOAD="https://github.com/boto/boto3/archive/1.3.1/boto3-1.3.1.tar.gz"
-MD5SUM="373315f35f5187cbf275e8bc44d943dd"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="botocore"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/boto3/slack-desc b/python/boto3/slack-desc
deleted file mode 100644
index 7ed633a59d..0000000000
--- a/python/boto3/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-boto3: boto3 (Python API for AWS)
-boto3:
-boto3: Boto is the Amazon Web Services (AWS) Software Development Kit (SDK)
-boto3: for Python, which allows Python developers to write software that
-boto3: makes use of services like Amazon S3 and Amazon EC2. You can find the
-boto3: latest, most up to date, documentation at `Read the Docs`_, including
-boto3: a list of services that are supported.
-boto3:
-boto3: Homepage: http://aws.amazon.com/sdk-for-python/
-boto3:
-boto3: