summaryrefslogtreecommitdiffstats
path: root/python/alabaster/alabaster.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/alabaster/alabaster.SlackBuild')
-rw-r--r--python/alabaster/alabaster.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/python/alabaster/alabaster.SlackBuild b/python/alabaster/alabaster.SlackBuild
index 0278a67414..ffc51ad38c 100644
--- a/python/alabaster/alabaster.SlackBuild
+++ b/python/alabaster/alabaster.SlackBuild
@@ -22,10 +22,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Update 2023-11-25: Removed python2 support
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=alabaster
-VERSION=${VERSION:-0.7.12}
+VERSION=${VERSION:-0.7.13}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,11 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if python3 -c 'import sys' 2>/dev/null; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true