summaryrefslogtreecommitdiffstats
path: root/python/WTForms/WTForms.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/WTForms/WTForms.SlackBuild')
-rw-r--r--python/WTForms/WTForms.SlackBuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/python/WTForms/WTForms.SlackBuild b/python/WTForms/WTForms.SlackBuild
index 680886f173..61895c199d 100644
--- a/python/WTForms/WTForms.SlackBuild
+++ b/python/WTForms/WTForms.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for WTForms
-# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
+# Copyright 2017-2020 Nikos Giotis <nikos.giotis@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=WTForms
-VERSION=${VERSION:-2.1}
+VERSION=${VERSION:-2.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,7 +60,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -71,11 +71,16 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install