summaryrefslogtreecommitdiffstats
path: root/python/PyStemmer/PyStemmer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/PyStemmer/PyStemmer.SlackBuild')
-rw-r--r--python/PyStemmer/PyStemmer.SlackBuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/python/PyStemmer/PyStemmer.SlackBuild b/python/PyStemmer/PyStemmer.SlackBuild
index ac8310efe6..365e5933ab 100644
--- a/python/PyStemmer/PyStemmer.SlackBuild
+++ b/python/PyStemmer/PyStemmer.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=PyStemmer
VERSION=${VERSION:-1.3.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -62,6 +62,11 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+
+# Patch for python 3.7 compatibility
+# https://github.com/snowballstem/pystemmer/pull/21/commits/b29ce2109f49c0b82517fa9d3e2bbacc1f8b34ec
+patch < $CWD/python-3.7-compatibility.patch
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -71,6 +76,9 @@ find -L . \
python setup.py install --root=$PKG
+#CFLAGS="$SLKCFLAGS" \
+python3 setup.py install --root=$PKG
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true