summaryrefslogtreecommitdiffstats
path: root/python/PyPDF2
diff options
context:
space:
mode:
Diffstat (limited to 'python/PyPDF2')
-rw-r--r--python/PyPDF2/PyPDF2.SlackBuild30
-rw-r--r--python/PyPDF2/PyPDF2.info10
-rw-r--r--python/PyPDF2/slack-desc2
3 files changed, 14 insertions, 28 deletions
diff --git a/python/PyPDF2/PyPDF2.SlackBuild b/python/PyPDF2/PyPDF2.SlackBuild
index 50ecac0f2e..e7fd2ff9c7 100644
--- a/python/PyPDF2/PyPDF2.SlackBuild
+++ b/python/PyPDF2/PyPDF2.SlackBuild
@@ -4,6 +4,7 @@
# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2023 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -54,28 +52,15 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="CHANGELOG LICENSE README.md"
SAMPLES="Scripts/ Sample_Code/ Resources/"
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
+rm -rvf $PKG
+mkdir -pv $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rvf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -83,8 +68,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
+python2 setup.py install --prefix=/usr --root=$PKG --optimize=1
+python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -92,6 +77,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -ar $DOCS $SAMPLES $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/PyPDF2/PyPDF2.info b/python/PyPDF2/PyPDF2.info
index 7350b3e4f9..92ed3e93d9 100644
--- a/python/PyPDF2/PyPDF2.info
+++ b/python/PyPDF2/PyPDF2.info
@@ -1,10 +1,10 @@
PRGNAM="PyPDF2"
VERSION="1.26.0"
-HOMEPAGE="https://mstamy2.github.io/PyPDF2/"
-DOWNLOAD="https://github.com/mstamy2/PyPDF2/archive/1.26.0/PyPDF2-1.26.0.tar.gz"
-MD5SUM="3959e3a15606e4b6c0405487cefb4e21"
+HOMEPAGE="https://pypi.org/project/PyPDF2/"
+DOWNLOAD="https://pypi.io/packages/source/P/PyPDF2/PyPDF2-1.26.0.tar.gz"
+MD5SUM="2301acc0ecbab0633d4c9b883d50ee5e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
+MAINTAINER="Vijay Marcel"
+EMAIL="vijaymarcel@outlook.com"
diff --git a/python/PyPDF2/slack-desc b/python/PyPDF2/slack-desc
index eaa7bfc90a..a625170a5c 100644
--- a/python/PyPDF2/slack-desc
+++ b/python/PyPDF2/slack-desc
@@ -12,7 +12,7 @@ PyPDF2: A Pure-Python library built as a PDF toolkit.
PyPDF2:
PyPDF2:
PyPDF2:
-PyPDF2:
+PyPDF2: Homepage:https://pypi.org/project/PyPDF2
PyPDF2:
PyPDF2:
PyPDF2: