summaryrefslogtreecommitdiffstats
path: root/python/Parsley
diff options
context:
space:
mode:
Diffstat (limited to 'python/Parsley')
-rw-r--r--python/Parsley/Parsley.SlackBuild96
-rw-r--r--python/Parsley/Parsley.info10
-rw-r--r--python/Parsley/README7
-rw-r--r--python/Parsley/slack-desc19
4 files changed, 0 insertions, 132 deletions
diff --git a/python/Parsley/Parsley.SlackBuild b/python/Parsley/Parsley.SlackBuild
deleted file mode 100644
index 4b3af780fd..0000000000
--- a/python/Parsley/Parsley.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Parsley
-#
-# Copyright 2016 Markus Reichelt, Aachen, DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Parsley
-VERSION=${VERSION:-1.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a NEWS LICENSE README PKG-INFO examples/ $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/Parsley/Parsley.info b/python/Parsley/Parsley.info
deleted file mode 100644
index 0264bcb2a8..0000000000
--- a/python/Parsley/Parsley.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Parsley"
-VERSION="1.3"
-HOMEPAGE="https://pypi.python.org/pypi/Parsley"
-DOWNLOAD="https://pypi.python.org/packages/06/52/cac2f9e78c26cff8bb518bdb4f2b5a0c7058dec7a62087ed48fe87478ef0/Parsley-1.3.tar.gz"
-MD5SUM="92bc256e5f73810a609dc7874637ad31"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-twisted"
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/Parsley/README b/python/Parsley/README
deleted file mode 100644
index a31f292942..0000000000
--- a/python/Parsley/README
+++ /dev/null
@@ -1,7 +0,0 @@
-Parsley uses the PEG algorithm, so each expression in the
-grammar rules works like a Python expression.
-In particular, alternatives are evaluated in order,
-unlike table-driven parsers such as yacc, bison or PLY.
-
-Parsley is an implementation of OMeta, an object-oriented
-pattern-matching language developed by Alessandro Warth.
diff --git a/python/Parsley/slack-desc b/python/Parsley/slack-desc
deleted file mode 100644
index 58ced34a3e..0000000000
--- a/python/Parsley/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Parsley: Parsley (Parsing and pattern matching in Python)
-Parsley:
-Parsley: https://pypi.python.org/pypi/Parsley
-Parsley:
-Parsley:
-Parsley:
-Parsley:
-Parsley:
-Parsley:
-Parsley:
-Parsley: