summaryrefslogtreecommitdiffstats
path: root/office/zathura/zathura.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/zathura/zathura.SlackBuild')
-rw-r--r--office/zathura/zathura.SlackBuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/office/zathura/zathura.SlackBuild b/office/zathura/zathura.SlackBuild
index e6729f3507..4f5130e113 100644
--- a/office/zathura/zathura.SlackBuild
+++ b/office/zathura/zathura.SlackBuild
@@ -23,6 +23,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240319 bkw: update for v0.5.4 and zathura-pdf-poppler 0.3.2.
+# These are the last versions that will build on Slackware 15.0
+# due to newer versions needing a newer pango.
+
+# 20230105 bkw: update for v0.5.1 and zathura-pdf-poppler 0.3.1.
+
# 20221114 bkw:
# - update for v0.5.1. zathura-pdf-poppler is still 0.3.0.
# - fix bash/zsh/fish completion.
@@ -40,7 +46,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zathura
-VERSION=${VERSION:-0.5.1}
+VERSION=${VERSION:-0.5.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,7 +55,7 @@ PKGTYPE=${PKGTYPE:-tgz}
# plugins. This build includes the default PDF plugin, without which zathura
# is completely useless.
PLUGIN=$PRGNAM-pdf-poppler
-PLUGINVER=${PLUGINVER:-0.3.0}
+PLUGINVER=${PLUGINVER:-0.3.2}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -98,6 +104,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
fixperms
+# 20240319 bkw: upstream decided we needed a newer meson, but this
+# builds just fine with our older one.
+sed -i '/meson_version/s,>=0\.61,>=0.59,' meson.build
+
# 20221114 bkw: Maik Wagner and Alexander Verbovetsky reported that
# fish and bash completion weren't working, due to the symlink I use
# to switch between the PDF plugins. This patch should fix it.
@@ -146,6 +156,7 @@ if [ "${POPPLER:-yes}" != "no" ]; then
tar xvf $CWD/$PLUGIN-$PLUGINVER.tar.gz
cd $PLUGIN-$PLUGINVER
fixperms
+ sed -i '/meson_version/s,>=0\.61,>=0.59,' meson.build
export PKG_CONFIG_PATH=$PKG/usr/lib$LIBDIRSUFFIX/pkgconfig:$PKG_CONFIG_PATH