summaryrefslogtreecommitdiffstats
path: root/office/xournalpp/xournalpp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/xournalpp/xournalpp.SlackBuild')
-rw-r--r--office/xournalpp/xournalpp.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/office/xournalpp/xournalpp.SlackBuild b/office/xournalpp/xournalpp.SlackBuild
index 006fa746b8..90792edb9a 100644
--- a/office/xournalpp/xournalpp.SlackBuild
+++ b/office/xournalpp/xournalpp.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xournalpp
-VERSION=${VERSION:-1.1.1}
+VERSION=${VERSION:-1.2.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,6 +79,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Set the right Lua version to use, otherwise it will use an older
+# version, if more than one installed.
+# Thanks to fourtysixandtwo (fourtysixandtwo@sliderr.net)
+sed -i 's/^find_package(Lua/find_package(Lua 5.3/' CMakeLists.txt
+
mkdir -p build
cd build
cmake \