summaryrefslogtreecommitdiffstats
path: root/office/wps-office/wps-office.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/wps-office/wps-office.SlackBuild')
-rw-r--r--office/wps-office/wps-office.SlackBuild54
1 files changed, 36 insertions, 18 deletions
diff --git a/office/wps-office/wps-office.SlackBuild b/office/wps-office/wps-office.SlackBuild
index 5d6dd39e54..e77d76e0f5 100644
--- a/office/wps-office/wps-office.SlackBuild
+++ b/office/wps-office/wps-office.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for wps-office
+# Copyright 2023 Petar Petrov, slackalaxy at gmail dot com
# Copyright 2016 Andre Fernando, Indonesia
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230627 bkw: Modified by SlackBuilds.org, BUILD=3:
+# - install all shared libaries with +x permission.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wps-office
-VERSION=${VERSION:-11.1.0.10920.XA}
+VERSION=${VERSION:-11.1.0.11711.XA}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,13 +51,10 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-SRCVER=${VERSION}
-
-case "$ARCH" in
- i?86) SRCARCH=i386 ;;
- x86_64) SRCARCH=amd64 ;;
- *) printf "\n\n$ARCH is not supported.\n"; exit 1 ;;
-esac
+if [ "$ARCH" != "x86_64" ]; then
+ printf "\n\n$ARCH is not supported... \n"
+ exit 1
+fi
set -e
@@ -66,18 +64,38 @@ cd $TMP
rm -rf $PRGNAM
mkdir -p $PRGNAM
cd $PRGNAM
-ar -x $CWD/${PRGNAM}_${SRCVER}_${SRCARCH}.deb
-tar xvf data.tar.xz -C $PKG
-cd $PKG
+ar -x $CWD/${PRGNAM}_${VERSION}_amd64.deb
+tar xvf data.tar.xz
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+# No WPS submenus, automatic file associations or redundant fonts (DejaVuMathTeXGyre.ttf)
+cp -a opt $PKG
+
+mkdir -p $PKG/usr
+cp -a usr/bin $PKG/usr
+
+# use our desktop files
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+cp --no-preserve=mode,ownership $CWD/desktop/*.desktop $PKG/usr/share/applications
+cp -a usr/share/icons/hicolor/48x48/mimetypes/wps-office2019-* $PKG/usr/share/pixmaps
+
+chmod 0644 $PKG/usr/share/pixmaps/wps-office2019-*
+
+find $PKG -print0 | xargs -0 file -m /etc/file/magic/elf \
+ | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : > .tmpfind.$$
+xargs strip --strip-unneeded < .tmpfind.$$ 2> /dev/null || true
+xargs chmod 755 < .tmpfind.$$ 2> /dev/null || true
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Thanks to NixOS (https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/office/wpsoffice/default.nix)
+# distribution is missing libkappessframework.so, so remove the following dead libraries
+rm -r $PKG/opt/kingsoft/wps-office/office6/addons/pdfbatchcompression
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild