summaryrefslogtreecommitdiffstats
path: root/office/pdf2djvu/pdf2djvu.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/pdf2djvu/pdf2djvu.SlackBuild')
-rw-r--r--office/pdf2djvu/pdf2djvu.SlackBuild32
1 files changed, 11 insertions, 21 deletions
diff --git a/office/pdf2djvu/pdf2djvu.SlackBuild b/office/pdf2djvu/pdf2djvu.SlackBuild
index 78fdabb85f..f685c67201 100644
--- a/office/pdf2djvu/pdf2djvu.SlackBuild
+++ b/office/pdf2djvu/pdf2djvu.SlackBuild
@@ -4,6 +4,7 @@
# Copyright 2010-2012 Binh Nguyen <binhvng@gmail.com>
# Copyright 2015-2018 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2023 Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +24,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# 20220218 bkw: Modified by SlackBuilds.org: updated to v0.9.18.2 as
-# the previous version wouldn't build on Slackware 15.0.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pdf2djvu
-VERSION=${VERSION:-0.9.18.2}
+VERSION=${VERSION:-0.9.19}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,7 +63,7 @@ else
LIBDIRSUFFIX=""
fi
-set -eu
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -80,18 +78,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-sed -i 's/poppler-splash/poppler/g' configure
-
-# 20220218 bkw: grrr. no option to disable -Werror, not even by
-# overriding in CFLAGS/CXXFLAGS. for gcc-11.2.0, it doesn't matter,
-# but this future-proofs us against the day post-15.0 -current
-# gets a gcc upgrade:
-sed -i '/-Werror/d' configure.ac
-autoreconf -if
-
-# 20220218 bkw: no install-strip target, but this worx.
-SLKCFLAGS+=" -Wl,-s"
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -100,19 +86,23 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --infodir=/usr/info \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--localedir=/usr/share/locale \
--build=$ARCH-slackware-linux
make
-make test
make install DESTDIR=$PKG
-gzip -9 $PKG/usr/man/{man1,??/man1}/*.1
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a doc/README doc/COPYING doc/changelog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/README doc/djvudigital doc/changelog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install