summaryrefslogtreecommitdiffstats
path: root/office/org-mode/org-mode.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/org-mode/org-mode.SlackBuild')
-rw-r--r--office/org-mode/org-mode.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/office/org-mode/org-mode.SlackBuild b/office/org-mode/org-mode.SlackBuild
index 94b368ecbe..4b58cf25d8 100644
--- a/office/org-mode/org-mode.SlackBuild
+++ b/office/org-mode/org-mode.SlackBuild
@@ -5,7 +5,7 @@
# Written by Valeriy Timchenko <ValTimchenko@gmail.com>
PRGNAM=org-mode
-VERSION=${VERSION:-6.36c}
+VERSION=${VERSION:-7.01g}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,11 +53,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-patch Makefile $CWD/Makefile.1.patch
-make
-patch Makefile $CWD/Makefile.2.patch
-PKG=$PKG make install
-PKG=$PKG make install-info
+patch Makefile $CWD/Makefile.patch
+DESTDIR=/usr make
+DESTDIR=/usr make doc
+DESTDIR=$PKG/usr make install
+DESTDIR=$PKG/usr PKG=$PKG make install-info
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -66,8 +66,8 @@ rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog Changes.org README request-assign-future.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Changes.org README request-assign-future.txt \
+ doc/*.pdf doc/*.html $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install