summaryrefslogtreecommitdiffstats
path: root/office/krop
diff options
context:
space:
mode:
Diffstat (limited to 'office/krop')
-rw-r--r--office/krop/README15
-rw-r--r--office/krop/krop.SlackBuild31
-rw-r--r--office/krop/krop.info8
-rw-r--r--office/krop/slack-desc8
4 files changed, 26 insertions, 36 deletions
diff --git a/office/krop/README b/office/krop/README
index 780083460d..c6c208c595 100644
--- a/office/krop/README
+++ b/office/krop/README
@@ -1,7 +1,16 @@
-Krop is a simple graphical tool to crop the pages of PDF files. It is
-written in Python and relies on PyQt, python-poppler-qt4, and PyPDF for
-its functionality. It features automatic margin cropping.
+krop is a simple graphical tool to crop the pages of PDF files.
+
+It is written in Python and relies on python-poppler-qt5 or
+python3-PyMuPDF for rendering, and pypdf/python3-PyPDF2 or pikepdf or
+python3-PyMuPDF for cropping. It features automatic margin cropping.
Krop can automatically split pages into subpages to fit the limited
screen size of devices such as eReaders. This is particularly useful, if
your eReader does not support convenient scrolling.
+
+This script has no build dependencies.
+
+Two runtime dependencies to be choosen from the following options:
+* python-poppler-qt5 or python3-PyMuPDF
+* pypdf (version > 3) or python3-PyPDF2 or pikepdf or python3-PyMuPDF
+They are autodetected or set manually using options.
diff --git a/office/krop/krop.SlackBuild b/office/krop/krop.SlackBuild
index d1dd7f527c..44d0c56cb5 100644
--- a/office/krop/krop.SlackBuild
+++ b/office/krop/krop.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for krop
-# Copyright 2018-2020, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2018-2024, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=krop
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-0.6.1_e96d42b}
+COMMIT="e96d42b2f1ab4317efe37cab498b708663bc104c"
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,28 +48,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -79,10 +63,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
python3 setup.py install --root=$PKG
-sed -i "s|krop==0.6.0|krop|g" $PKG/usr/bin/krop
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/office/krop/krop.info b/office/krop/krop.info
index f0c0393ba4..bd03c0a489 100644
--- a/office/krop/krop.info
+++ b/office/krop/krop.info
@@ -1,10 +1,10 @@
PRGNAM="krop"
-VERSION="0.6.0"
+VERSION="0.6.1_e96d42b"
HOMEPAGE="http://arminstraub.com/computer/krop"
-DOWNLOAD="https://github.com/arminstraub/krop/archive/v0.6.0/krop-0.6.0.tar.gz"
-MD5SUM="8bf9e9d64a4f7b749980a14dc699f96a"
+DOWNLOAD="https://github.com/arminstraub/krop/archive/e96d42b/krop-e96d42b2f1ab4317efe37cab498b708663bc104c.tar.gz"
+MD5SUM="9ddb0caa00585882e4d3b081bf5b3b4f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-poppler-qt5 PyPDF2"
+REQUIRES="%README% python-poppler-qt5 python3-pypdf"
MAINTAINER="Alexander Verbovetsky"
EMAIL="alik@ejik.org"
diff --git a/office/krop/slack-desc b/office/krop/slack-desc
index 70a7966932..16e3c34354 100644
--- a/office/krop/slack-desc
+++ b/office/krop/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
krop: krop (a tool to crop pdf files)
krop:
-krop: Krop is a simple graphical tool to crop the pages of PDF files. It is
-krop: written in Python and relies on PyQt, python-poppler-qt4, and PyPDF
-krop: for its functionality. It features automatic margin cropping.
+krop: krop is a simple graphical tool to crop the pages of PDF files. It is
+krop: written in Python and relies on python-poppler-qt5 or PyMuPDF for
+krop: rendering, and pypdf/PyPDF2 or pikepdf or PyMuPDF for cropping. It
+krop: features automatic margin cropping.
krop:
krop:
krop: Homepage: http://arminstraub.com/computer/krop
krop:
krop:
-krop: