summaryrefslogtreecommitdiffstats
path: root/office/khard
diff options
context:
space:
mode:
Diffstat (limited to 'office/khard')
-rw-r--r--office/khard/khard.SlackBuild7
-rw-r--r--office/khard/khard.info10
2 files changed, 10 insertions, 7 deletions
diff --git a/office/khard/khard.SlackBuild b/office/khard/khard.SlackBuild
index 68afea152b..c55da17b8b 100644
--- a/office/khard/khard.SlackBuild
+++ b/office/khard/khard.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=khard
-VERSION=${VERSION:-0.17.0}
+VERSION=${VERSION:-0.19.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,7 +76,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 setup.py install --root=$PKG
# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/office/khard/khard.info b/office/khard/khard.info
index 3b28899743..7e5cd97d46 100644
--- a/office/khard/khard.info
+++ b/office/khard/khard.info
@@ -1,10 +1,10 @@
PRGNAM="khard"
-VERSION="0.17.0"
+VERSION="0.19.1"
HOMEPAGE="https://github.com/scheibler/khard/"
-DOWNLOAD="https://files.pythonhosted.org/packages/a3/4e/e9cbcb281d371c355f251e5d9ca58b7e0d02dffd2bf4938888068fbc2def/khard-0.17.0.tar.gz"
-MD5SUM="f0dacd681735c828af130906dc656f49"
+DOWNLOAD="https://files.pythonhosted.org/packages/0d/00/215a69d2ae96cac511a6594116958bf13e210dd24f78c48f5ffaf039edec/khard-0.19.1.tar.gz"
+MD5SUM="2659cd0e0038ab1d81c50ea51b3d4951"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Unidecode python3-dateutil vobject python-ruamel.yaml atomicwrites configobj"
+REQUIRES="python3-setuptools-opt Unidecode vobject python3-ruamel.yaml python3-atomicwrites configobj"
MAINTAINER="Tonus"
-EMAIL="tonus1@gmail.com"
+EMAIL="tonus1@free.fr"