summaryrefslogtreecommitdiffstats
path: root/office/khard/khard.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/khard/khard.SlackBuild')
-rw-r--r--office/khard/khard.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/office/khard/khard.SlackBuild b/office/khard/khard.SlackBuild
index 68afea152b..c55da17b8b 100644
--- a/office/khard/khard.SlackBuild
+++ b/office/khard/khard.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=khard
-VERSION=${VERSION:-0.17.0}
+VERSION=${VERSION:-0.19.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,7 +76,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 setup.py install --root=$PKG
# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \