summaryrefslogtreecommitdiffstats
path: root/office/grisbi/grisbi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/grisbi/grisbi.SlackBuild')
-rw-r--r--office/grisbi/grisbi.SlackBuild38
1 files changed, 18 insertions, 20 deletions
diff --git a/office/grisbi/grisbi.SlackBuild b/office/grisbi/grisbi.SlackBuild
index 1384b6fff1..2b20231722 100644
--- a/office/grisbi/grisbi.SlackBuild
+++ b/office/grisbi/grisbi.SlackBuild
@@ -2,28 +2,26 @@
# Slackware build script for grisbi
-# Written by Larry Hajali
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=grisbi
-VERSION=${VERSION:-0.6.0b2}
+VERSION=0.6.0
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -44,7 +42,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION-1.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -53,8 +51,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix the HELP_PATH so that the help menu looks in /usr/doc/$PRGNAM-$VERSION.
-patch -p1 < $CWD/help-menu.patch
+# Fix the HELP_PATH so that the help menu looks in /usr/doc/grisbi-$VERSION.
+sed -i \
+ -e "/^grisbi_helpdir/s|/doc||g" \
+ -e "/^AM_CPPFLAGS/s|/doc||g" \
+ src/Makefile.* help/*/Makefile.*
+# Fix .desktop menu item.
+sed -i \
+ -e "s|$PRGNAM.png|$PRGNAM|" \
+ share/grisbi.desktop
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -76,14 +81,7 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-# Grisbi comes with a desktop menu item but we're going to overwrite it.
-mkdir -p $PKG/usr/share/applications
-install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \