summaryrefslogtreecommitdiffstats
path: root/office/evince/evince.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/evince/evince.SlackBuild')
-rw-r--r--office/evince/evince.SlackBuild25
1 files changed, 3 insertions, 22 deletions
diff --git a/office/evince/evince.SlackBuild b/office/evince/evince.SlackBuild
index a1f6e48489..b944aacad0 100644
--- a/office/evince/evince.SlackBuild
+++ b/office/evince/evince.SlackBuild
@@ -33,7 +33,7 @@
# some fugly hackery to work, see shim.h for gory details and polemic.
PRGNAM=evince
-VERSION=${VERSION:-3.28.5}
+VERSION=${VERSION:-3.34.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -89,20 +89,6 @@ if [ "$NLS" != "YES" ]; then
-e 's/ENABLE_NLS 1/ENABLE_NLS 0/g' configure
fi
-# 20200101 bkw: "shim" to let us actually compile with gtk+-3.18 and
-# glib-2.46.2. Supposedly these versions are supported by evince-3.28.5,
-# but upstream uses a couple of functions that are new in gtk+-3.22
-# and glib-2.52. Fortunately it's stuff we can work around with a few
-# #defines.
-SLKCFLAGS="$SLKCFLAGS -include $CWD/shim.h"
-
-# 20200101 bkw: 14.2's mime stuff identifies djvu files as
-# image/vnd.djvu only, but evince wants image/vnd.djvu+multipage.
-sed -i '/^ *DJVU_MIME_TYPES/s|="|&image/vnd.djvu;|' configure
-
-# If we were building 3.30.x, we'd need this:
-# --without-gspell \
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -126,23 +112,18 @@ CXXFLAGS="$SLKCFLAGS" \
--disable-static \
--disable-nautilus \
--disable-maintainer-mode \
+ --without-gspell \
--with-systemduserunitdir=no \
--build=$ARCH-slackware-linux
-# ugh. glib-genmarshal's flags changed gratuitously.
-sed -i 's,--prototypes,--header,' libview/Makefile
-
make V=1
make install-strip DESTDIR=$PKG
-# Fix desktop entry
-sed -i "/NoDisplay=true/d" $PKG/usr/share/applications/evince.desktop
-
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
rm -rf $PKG/{usr/share/gtk-doc,etc}
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING NEWS README MAINTAINERS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING NEWS README.md MAINTAINERS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install