summaryrefslogtreecommitdiffstats
path: root/office/asymptote/asymptote.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/asymptote/asymptote.SlackBuild')
-rw-r--r--office/asymptote/asymptote.SlackBuild39
1 files changed, 27 insertions, 12 deletions
diff --git a/office/asymptote/asymptote.SlackBuild b/office/asymptote/asymptote.SlackBuild
index b3fc58ca1b..3c9d7da655 100644
--- a/office/asymptote/asymptote.SlackBuild
+++ b/office/asymptote/asymptote.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for asymptote
-# Copyright 2016 - 2022 Johannes Schoepfer, Germany
+# Copyright 2016-2024 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=asymptote
-VERSION=${VERSION:-2.70}
+VERSION=${VERSION:-2.88}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +72,12 @@ cd asymptote-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+# To build the complete docs, some packages from texlive-extra are required.
+DOC=${DOC:-no}
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -90,16 +90,28 @@ CFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--enable-gc=system \
--enable-offscreen \
+ --disable-lsp \
+ --disable-gc-debug \
+ --disable-gc-full-debug \
--with-latex=/usr/share/texmf-dist/tex/latex \
--with-context=/usr/share/texmf-dist/tex/context \
--datarootdir=/usr/share/texmf-dist \
--build=$ARCH-slackware-linux
+if [ $DOC = no ]; then
+sed -i doc/Makefile \
+ -e "s/ latexusage.pdf//g" \
+ -e "s/pdflatex latexusage//g" \
+ -e "s/ asymptote.pdf//g" \
+ -e "/pdflatex CAD/d" \
+ -e "s/CAD.pdf//" \
+ -e "s/TeXShopAndAsymptote.pdf//"
+fi
+
make
make check
make install DESTDIR=$PKG
-rm -rf $PKG/usr/info/asymptote
mkdir -p $PKG/usr/share/vim/vimfiles/syntax
mv $PKG/usr/share/texmf-dist/asymptote/*.vim $PKG/usr/share/vim/vimfiles/syntax
(
@@ -119,15 +131,18 @@ find $PKG/usr/man -type f -exec gzip -9 {} +
for links in $(find $PKG/usr/man -type l ) ; do ln -sf $( readlink $links ).gz $links.gz;rm $links;done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv BUGS ChangeLog INSTALL LICENSE LICENSE.LESSER README TODO \
+mv BUGS ChangeLog LICENSE LICENSE.LESSER README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cd $PKG/usr/info
-find . -type f -exec gzip -9 {} +
-for links in $(find . -type l ) ; do ln -sf $( readlink $links ).gz $links.gz;rm $links;done
+mv $PKG/usr/info/asymptote/asymptote.info $PKG/usr/info/
+rmdir $PKG/usr/info/asymptote
+find $PKG/usr/info -name '*.info*' -type f -exec gzip -9 {} +
mkdir $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/douninst.sh > $PKG/install/douninst.sh
+
cd $PKG
/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE