summaryrefslogtreecommitdiffstats
path: root/office/LibreOffice
diff options
context:
space:
mode:
Diffstat (limited to 'office/LibreOffice')
-rw-r--r--office/LibreOffice/LibreOffice.SlackBuild38
-rw-r--r--office/LibreOffice/LibreOffice.info10
-rw-r--r--office/LibreOffice/README4
-rw-r--r--office/LibreOffice/bison_yyn-yyrule_rename.diff18
-rw-r--r--office/LibreOffice/skia-freetype-2.11.diff51
5 files changed, 33 insertions, 88 deletions
diff --git a/office/LibreOffice/LibreOffice.SlackBuild b/office/LibreOffice/LibreOffice.SlackBuild
index 23153e0703..82f03e2264 100644
--- a/office/LibreOffice/LibreOffice.SlackBuild
+++ b/office/LibreOffice/LibreOffice.SlackBuild
@@ -4,7 +4,7 @@
# Slackware build script for LibreOffice
-# Copyright 2015-2022 Christoph Willing Brisbane, Australia
+# Copyright 2015-2024 Christoph Willing Sydney, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=LibreOffice
SRCNAM=libreoffice
-VERSION=${VERSION:-7.3.4.2}
+VERSION=${VERSION:-24.8.1.2}
SHORT_VERSION=${VERSION%.*.*}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,6 +69,18 @@ else
LIBDIRSUFFIX=""
fi
+if [ -x /usr/bin/gcc-11.* ];
+then
+ echo Slackware-15.0
+ export CC=/usr/bin/clang
+ export CXX=/usr/bin/clang++
+ CXXCLANGFLAGS="-Wno-c++11-narrowing"
+else
+ echo Slackware-15.0++
+ export CC=/usr/bin/gcc
+ export CXX=/usr/bin/g++
+fi
+
set -e
rm -rf $PKG
@@ -163,6 +175,7 @@ if pkg-config --exists mdds-1.4 ; then mdds="--with-system-mdds" ; else mdds=""
if pkg-config --exists mythes ; then mythes="--with-system-mythes" ; else mythes="" ; fi
if test -x /usr/bin/odbc_config ; then odbc="--with-system-odbc" ; else odbc="" ; fi
#if test -d /usr/lib${LIBDIRSUFFIX}/python3*/site-packages/lxml ; then lxml="--with-system-lxml" ; else lxml="" ; fi
+
if pkg-config --exists xmlsec1 ; then
xmlsec="--with-system-xmlsec"
else
@@ -170,6 +183,7 @@ else
# Also ensure correct nspr implementation is used if building libreoffice supplied xmlsec
sed -i -e 's:openssl:openssl --with-mozilla-ver=/usr:' external/xmlsec/ExternalProject_xmlsec.mk
fi
+
#if test -e /usr/share/ant/lib/rhino.jar ; then rhino="--with-system-rhino --with-rhino-jar=/usr/share/ant/lib/rhino.jar" ; else rhino="" ; fi
if pkg-config --exists libvlc ; then vlc="--enable-vlc" ; else vlc="" ; fi
# Building with vlc backend is marked as experimental so demand explicit indication via environment variable VLC to do it.
@@ -189,9 +203,11 @@ extwikipub="--enable-ext-wiki-publisher"; [ "${EXTWIKIPUB:-no}" != "yes" ] &
extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] && extnlpsolver=""
-./autogen.sh \
+
+./configure \
CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS $CXXCLANGFLAGS" \
+ LDFLAGS="-lz" \
NSS_CFLAGS="$(pkg-config --cflags-only-I mozilla-nss)"\
--prefix=/usr \
--mandir=/usr/man \
@@ -220,10 +236,9 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
--without-krb5 \
--without-gssapi \
--without-junit \
+ --without-system-libxml \
--with-help \
- --with-system-apr \
--with-system-bluez \
- --with-system-boost \
--with-system-bzip2 \
--with-system-cairo \
--with-system-clucene \
@@ -232,18 +247,17 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
--with-system-epoxy \
--with-system-expat \
--with-system-hunspell \
- --with-system-icu \
--with-system-jpeg \
--with-system-lcms2 \
--with-system-libodfgen \
--with-system-libpng \
--with-system-librevenge \
+ --with-system-libtiff \
--with-system-libvisio \
+ --with-system-libwebp \
--with-system-libwpd \
--with-system-libwpg \
- --with-system-libxml \
--with-system-mariadb \
- --with-system-neon \
--with-system-nss \
--with-system-openldap \
--with-system-openssl \
@@ -255,6 +269,7 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
$glm \
$libabw \
$libcdr \
+ $liblangtag \
$libcmis \
$libebook \
$libeot \
@@ -293,16 +308,13 @@ if [ "$HAVE_SRCS_TARBALL" = "0" ]; then
fi
patch -p0 < $CWD/no-check-if-root.diff
-#patch -p0 < $CWD/skia-freetype-2.11.diff
-#patch -p0 < $CWD/bison_yyn-yyrule_rename.diff
# GCC10 requirements (Tx alienBOB)
sed -i external/libebook/ExternalProject_libebook.mk \
-e '/configure /i \\t\t&& sed -i "s/TRUE/true/g" src/lib/EBOOKCharsetConverter.cpp \\'
-export LDFLAGS="-lboost_system"
-make build-nocheck
+make build
make distro-pack-install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/office/LibreOffice/LibreOffice.info b/office/LibreOffice/LibreOffice.info
index 57802e1129..bfc2662353 100644
--- a/office/LibreOffice/LibreOffice.info
+++ b/office/LibreOffice/LibreOffice.info
@@ -1,10 +1,12 @@
PRGNAM="LibreOffice"
-VERSION="7.3.4.2"
+VERSION="24.8.1.2"
HOMEPAGE="https://www.libreoffice.org"
-DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.3.4/libreoffice-7.3.4.2.tar.xz"
-MD5SUM="5f3fed3e78801d6ed4661bc76b82e919"
+DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/24.8.1/libreoffice-24.8.1.2.tar.xz \
+ https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-24.8.1.2-srcs.tar.xz"
+MD5SUM="b35207353549e450d280c11fc8a15ccd \
+ 9d8e5935e4101aca7f2987e93ea12bfb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="zulu-openjdk11 apache-ant perl-Archive-Zip"
+REQUIRES="zulu-openjdk17 apache-ant perl-Archive-Zip libcdr libfreehand liblangtag libmspub libzmf"
MAINTAINER="Christoph Willing"
EMAIL="chris.willing@linux.com"
diff --git a/office/LibreOffice/README b/office/LibreOffice/README
index 6cb98faa77..3adeba09ef 100644
--- a/office/LibreOffice/README
+++ b/office/LibreOffice/README
@@ -73,12 +73,12 @@ as follows:
default due to interference with Openshot (therefore possibly other
packages). It may be enabled by setting the PYUNO environment
variable e.g.
- PYUNO=yes sh LibreOffice.SlackBuild
+ PYUNO=yes sh LibreOffice.SlackBuild
Even without PyUNO enabled in this way, PyUNO scripts may still be
executed by suitably extending the PYTHONPATH in the environment at
runtime e.g.
- PYTHONPATH=/usr/lib64/libreoffice/program my_python_uno_script.py
+ PYTHONPATH=/usr/lib64/libreoffice/program my_python_uno_script.py
Spell checking of documents at runtime requires installation of a
diff --git a/office/LibreOffice/bison_yyn-yyrule_rename.diff b/office/LibreOffice/bison_yyn-yyrule_rename.diff
deleted file mode 100644
index 9802135098..0000000000
--- a/office/LibreOffice/bison_yyn-yyrule_rename.diff
+++ /dev/null
@@ -1,18 +0,0 @@
---- connectivity/source/parse/sqlbison.y.orig 2021-09-18 13:35:17.897000000 +1000
-+++ connectivity/source/parse/sqlbison.y 2021-09-18 13:32:58.864000000 +1000
-@@ -74,9 +74,15 @@
-
- // yyi is the internal number of the rule that is currently being reduced
- // This can be mapped to external rule number via the yyrmap.
-+#if defined YYBISON && YYBISON >= 30800
-+#define SQL_NEW_RULE newNode("", SQLNodeType::Rule, yyr1[yyrule])
-+#define SQL_NEW_LISTRULE newNode("", SQLNodeType::ListRule, yyr1[yyrule])
-+#define SQL_NEW_COMMALISTRULE newNode("", SQLNodeType::CommaListRule, yyr1[yyrule])
-+#else
- #define SQL_NEW_RULE newNode("", SQLNodeType::Rule, yyr1[yyn])
- #define SQL_NEW_LISTRULE newNode("", SQLNodeType::ListRule, yyr1[yyn])
- #define SQL_NEW_COMMALISTRULE newNode("", SQLNodeType::CommaListRule, yyr1[yyn])
-+#endif
-
-
- extern connectivity::OSQLParser* xxx_pGLOBAL_SQLPARSER;
diff --git a/office/LibreOffice/skia-freetype-2.11.diff b/office/LibreOffice/skia-freetype-2.11.diff
deleted file mode 100644
index 73d16e6ead..0000000000
--- a/office/LibreOffice/skia-freetype-2.11.diff
+++ /dev/null
@@ -1,51 +0,0 @@
---- external/skia/UnpackedTarball_skia.mk.orig 2021-08-23 22:03:48.538000000 +1000
-+++ external/skia/UnpackedTarball_skia.mk 2021-08-23 22:04:58.137000000 +1000
-@@ -39,6 +39,7 @@
- fast-png-write.patch.1 \
- skia_sk_cpu_sse_level_0_by_default.patch.1 \
- fix-warnings.patch.1 \
-+ skia_freetype-2.11.patch.0 \
-
- $(eval $(call gb_UnpackedTarball_set_patchlevel,skia,1))
-
---- /dev/null 2021-08-23 17:37:05.741000000 +1000
-+++ external/skia/skia_freetype-2.11.patch.0 2021-08-23 22:01:05.176000000 +1000
-@@ -0,0 +1,38 @@
-+--- src/ports/SkFontHost_FreeType_common.cpp.orig 2021-03-02 00:53:09.178606791 +1000
-++++ src/ports/SkFontHost_FreeType_common.cpp 2021-08-23 21:58:57.678000000 +1000
-+@@ -665,8 +665,13 @@
-+ canvas->drawPaint(paint);
-+ break;
-+ }
-++#ifdef FREETYPE_MAJOR == 2 && FREETYPE_MINOR >= 11
-++ case FT_COLR_PAINTFORMAT_TRANSFORM: {
-++ SkMatrix transform = ToSkMatrix(colrv1_paint.u.transform.affine);
-++#else
-+ case FT_COLR_PAINTFORMAT_TRANSFORMED: {
-+ SkMatrix transform = ToSkMatrix(colrv1_paint.u.transformed.affine);
-++#endif
-+
-+ canvas->concat(transform);
-+ break;
-+@@ -760,12 +765,21 @@
-+ traverse_result = colrv1_start_glyph(canvas, palette, face, paint.u.colr_glyph.glyphID,
-+ FT_COLOR_NO_ROOT_TRANSFORM);
-+ break;
-++#ifdef FREETYPE_MAJOR == 2 && FREETYPE_MINOR >= 11
-++ case FT_COLR_PAINTFORMAT_TRANSFORM:
-++ canvas->saveLayer(nullptr, nullptr);
-++ // Traverse / draw operation will apply transform.
-++ colrv1_draw_paint(canvas, palette, face, paint);
-++ traverse_result =
-++ colrv1_traverse_paint(canvas, palette, face, paint.u.transform.paint);
-++#else
-+ case FT_COLR_PAINTFORMAT_TRANSFORMED:
-+ canvas->saveLayer(nullptr, nullptr);
-+ // Traverse / draw operation will apply transform.
-+ colrv1_draw_paint(canvas, palette, face, paint);
-+ traverse_result =
-+ colrv1_traverse_paint(canvas, palette, face, paint.u.transformed.paint);
-++#endif
-+ canvas->restore();
-+ break;
-+ case FT_COLR_PAINTFORMAT_ROTATE: