summaryrefslogtreecommitdiffstats
path: root/office/LibreOffice/libgpg-error.gawk5.diff
diff options
context:
space:
mode:
Diffstat (limited to 'office/LibreOffice/libgpg-error.gawk5.diff')
-rw-r--r--office/LibreOffice/libgpg-error.gawk5.diff49
1 files changed, 49 insertions, 0 deletions
diff --git a/office/LibreOffice/libgpg-error.gawk5.diff b/office/LibreOffice/libgpg-error.gawk5.diff
new file mode 100644
index 0000000000..d8842db4bc
--- /dev/null
+++ b/office/LibreOffice/libgpg-error.gawk5.diff
@@ -0,0 +1,49 @@
+--- ./src/Makefile.in.orig 2019-03-19 03:58:04.000000000 -0500
++++ ./src/Makefile.in 2019-04-13 13:58:45.614800729 -0500
+@@ -1615,7 +1615,7 @@
+
+ errnos-sym.h: Makefile mkstrtable.awk errnos.in
+ $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
+- -v prefix=GPG_ERR_ -v namespace=errnos_ \
++ -v prefix=GPG_ERR_ -v libgpg_error_namespace=errnos_ \
+ $(srcdir)/errnos.in >$@
+
+ mkheader$(EXEEXT_FOR_BUILD): mkheader.c Makefile
+--- ./src/mkstrtable.awk.orig 2013-03-15 14:24:25.000000000 -0500
++++ ./src/mkstrtable.awk 2019-04-13 13:57:47.141800103 -0500
+@@ -77,7 +77,7 @@
+ #
+ # The variable prefix can be used to prepend a string to each message.
+ #
+-# The variable namespace can be used to prepend a string to each
++# The variable libgpg_error_namespace can be used to prepend a string to each
+ # variable and macro name.
+
+ BEGIN {
+@@ -102,7 +102,7 @@
+ print "/* The purpose of this complex string table is to produce";
+ print " optimal code with a minimum of relocations. */";
+ print "";
+- print "static const char " namespace "msgstr[] = ";
++ print "static const char " libgpg_error_namespace "msgstr[] = ";
+ header = 0;
+ }
+ else
+@@ -150,7 +150,7 @@
+ else
+ print " gettext_noop (\"" last_msgstr "\");";
+ print "";
+- print "static const int " namespace "msgidx[] =";
++ print "static const int " libgpg_error_namespace "msgidx[] =";
+ print " {";
+ for (i = 0; i < coded_msgs; i++)
+ print " " pos[i] ",";
+@@ -158,7 +158,7 @@
+ print " };";
+ print "";
+ print "static GPG_ERR_INLINE int";
+- print namespace "msgidxof (int code)";
++ print libgpg_error_namespace "msgidxof (int code)";
+ print "{";
+ print " return (0 ? 0";
+