summaryrefslogtreecommitdiffstats
path: root/network/vimb
diff options
context:
space:
mode:
Diffstat (limited to 'network/vimb')
-rw-r--r--network/vimb/Makefile.patch11
-rw-r--r--network/vimb/README4
-rw-r--r--network/vimb/doinst.sh3
-rw-r--r--network/vimb/slack-desc19
-rw-r--r--network/vimb/vimb.SlackBuild103
-rw-r--r--network/vimb/vimb.info10
6 files changed, 0 insertions, 150 deletions
diff --git a/network/vimb/Makefile.patch b/network/vimb/Makefile.patch
deleted file mode 100644
index 88b76c6e3d..0000000000
--- a/network/vimb/Makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.orig 2018-06-28 04:21:53.000000000 +0200
-+++ src/Makefile 2018-06-28 04:21:22.000000000 +0200
-@@ -16,6 +16,8 @@
-
- $(OBJ): config.h ../config.mk
-
-+input.o: scripts/scripts.h
-+
- normal.o: scripts/scripts.h
-
- setting.o: scripts/scripts.h
diff --git a/network/vimb/README b/network/vimb/README
deleted file mode 100644
index ed41db2e58..0000000000
--- a/network/vimb/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Vimb is a Vim-like web browser that is inspired by Pentadactyl and
-Vimprobable. The goal of Vimb is to build a completely keyboard-driven,
-efficient and pleasurable browsing experience with low memory and CPU
-usage that is intuitive to use for Vim users.
diff --git a/network/vimb/doinst.sh b/network/vimb/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/network/vimb/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/network/vimb/slack-desc b/network/vimb/slack-desc
deleted file mode 100644
index 308a2168ef..0000000000
--- a/network/vimb/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-vimb: vimb (keyboard-driven, vim-like web browser)
-vimb:
-vimb: Vimb is a webkit2gtk-based browser inspired by Pentadactyl and
-vimb: Vimprobable. The goal of Vimb is to build a completely
-vimb: keyboard-driven, efficient and pleasurable browsing experience with
-vimb: low memory and CPU usage that is intuitive to use for Vim users.
-vimb:
-vimb: Homepage: https://fanglingsu.github.io/vimb
-vimb:
-vimb:
-vimb:
diff --git a/network/vimb/vimb.SlackBuild b/network/vimb/vimb.SlackBuild
deleted file mode 100644
index 153a86dcd3..0000000000
--- a/network/vimb/vimb.SlackBuild
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for vimb
-
-# Copyright 2015-2017 Leonard Schmidt <lems@gmx.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=vimb
-VERSION=${VERSION:-3.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch -p0 < $CWD/Makefile.patch
-
-make \
- PREFIX=/usr \
- DESTDIR="$PKG" \
- MANPREFIX="$PKG"/usr/man \
- LIBDIR="$PKG"/usr/lib${LIBDIRSUFFIX}/vimb \
- EXTENSIONDIR=/usr/lib${LIBDIRSUFFIX}/vimb \
- install
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/vimb/vimb.info b/network/vimb/vimb.info
deleted file mode 100644
index 8f03b4d82b..0000000000
--- a/network/vimb/vimb.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="vimb"
-VERSION="3.2.0"
-HOMEPAGE="https://fanglingsu.github.io/vimb"
-DOWNLOAD="https://github.com/fanglingsu/vimb/archive/3.2.0/vimb-3.2.0.tar.gz"
-MD5SUM="c0848041b6f6d618d5d4d0e169c1ea5c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="webkit2gtk"
-MAINTAINER="Leonard Schmidt"
-EMAIL="lems@gmx.net"