summaryrefslogtreecommitdiffstats
path: root/network/tahoe-lafs
diff options
context:
space:
mode:
Diffstat (limited to 'network/tahoe-lafs')
-rw-r--r--network/tahoe-lafs/README16
-rw-r--r--network/tahoe-lafs/slack-desc19
-rw-r--r--network/tahoe-lafs/tahoe-lafs.SlackBuild109
-rw-r--r--network/tahoe-lafs/tahoe-lafs.info10
4 files changed, 0 insertions, 154 deletions
diff --git a/network/tahoe-lafs/README b/network/tahoe-lafs/README
deleted file mode 100644
index a8b2c6de9d..0000000000
--- a/network/tahoe-lafs/README
+++ /dev/null
@@ -1,16 +0,0 @@
-Tahoe, the Least-Authority File Store.
-
-Tahoe-LAFS is a secure, decentralized, file store. All of the source
-code is available under a choice of two Free Software, Open Source
-licences.
-
-The file store is encrypted and spread over multiple peers in such a way
-that it remains available even when some of the peers are unavailable,
-malfunctioning, or malicious.
-
-Tahoe-LAFS now features native Tor and I2P support.
-
-Optional Dependency
-
-In case you'd like proper documentation to be build Sphinx needs to be
-installed at build time.
diff --git a/network/tahoe-lafs/slack-desc b/network/tahoe-lafs/slack-desc
deleted file mode 100644
index 97dfb4e23e..0000000000
--- a/network/tahoe-lafs/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-tahoe-lafs: tahoe-lafs (Secure File Store)
-tahoe-lafs:
-tahoe-lafs: Tahoe, the Least-Authority File Store.
-tahoe-lafs: Tahoe-LAFS is a secure, decentralized, file store. The file store
-tahoe-lafs: is encrypted and spread over multiple peers in such a way that it
-tahoe-lafs: remains available even when some of the peers are unavailable,
-tahoe-lafs: malfunctioning, or malicious.
-tahoe-lafs:
-tahoe-lafs: Homepage: https://tahoe-lafs.org/
-tahoe-lafs:
-tahoe-lafs:
diff --git a/network/tahoe-lafs/tahoe-lafs.SlackBuild b/network/tahoe-lafs/tahoe-lafs.SlackBuild
deleted file mode 100644
index cdd46e5491..0000000000
--- a/network/tahoe-lafs/tahoe-lafs.SlackBuild
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for tahoe-lafs
-
-# Copyright 2009 Marco Bonetti <sid77@slackware.it>
-# Copyright 2011-2017 Markus Reichelt, Aachen, DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=tahoe-lafs
-VERSION=${VERSION:-1.12.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 \
- -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/man/man1
-cp -a COPYING.* *.txt NEWS.* README.* CREDITS docs misc $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mv $PKG/usr/doc/$PRGNAM-$VERSION/docs/man/man1/tahoe.1 $PKG/usr/man/man1
-gzip -9 $PKG/usr/man/man1/tahoe.1
-rm -drf $PKG/usr/doc/$PRGNAM-$VERSION/docs/man
-
-if [ -e /usr/bin/sphinx-build ]; then
- cd $TMP/$PRGNAM-$VERSION/docs
- make html
- cp -a _build/html $PKG/usr/doc/$PRGNAM-$VERSION
- rm $PKG/usr/doc/$PRGNAM-$VERSION/html/{.buildinfo,objects.inv}
- rm -drf $PKG/usr/doc/$PRGNAM-$VERSION/docs
- rm -drf $PKG/usr/doc/$PRGNAM-$VERSION/html/_sources
-fi
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/tahoe-lafs/tahoe-lafs.info b/network/tahoe-lafs/tahoe-lafs.info
deleted file mode 100644
index 059c98d777..0000000000
--- a/network/tahoe-lafs/tahoe-lafs.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="tahoe-lafs"
-VERSION="1.12.1"
-HOMEPAGE="https://tahoe-lafs.org/trac/tahoe-lafs"
-DOWNLOAD="https://tahoe-lafs.org/downloads/old/tahoe-lafs-1.12.1.tar.bz2"
-MD5SUM="617d9f33705570ae79795835dff8ff0d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="txtorcon txi2p simplejson python2-pycrypto pycryptopp zfec service_identity foolscap Nevow"
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"