summaryrefslogtreecommitdiffstats
path: root/network/sslscan/sslscan.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/sslscan/sslscan.SlackBuild')
-rw-r--r--network/sslscan/sslscan.SlackBuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/network/sslscan/sslscan.SlackBuild b/network/sslscan/sslscan.SlackBuild
index 1f399c5419..a46dffe652 100644
--- a/network/sslscan/sslscan.SlackBuild
+++ b/network/sslscan/sslscan.SlackBuild
@@ -33,9 +33,7 @@
# 2014-10-23 - changed to build rbsec's fork from github
PRGNAM=sslscan
-VERSION=${VERSION:-1.11.8_rbsec}
-SRCVERS=$(echo "$VERSION" | tr _ -)
-BASEVERS=$(echo "$VERSION" | sed 's/_.*$//' )
+VERSION=${VERSION:-1.11.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,13 +69,13 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVERS
-tar xvf $CWD/$PRGNAM-$SRCVERS.tar.gz
-cd $PRGNAM-$SRCVERS
+rm -rf $PRGNAM-$VERSION-rbsec
+tar xvf $CWD/$PRGNAM-$VERSION-rbsec.tar.gz
+cd $PRGNAM-$VERSION-rbsec
patch -p1 < $CWD/Makefile.diff
-sed -i "s/^GIT_VERSION = .*$/GIT_VERSION = $BASEVERS/" Makefile
+sed -i "s/^GIT_VERSION = .*$/GIT_VERSION = $VERSION/" Makefile
STATIC=${STATIC:-yes}
@@ -102,9 +100,9 @@ sed -i "s|^\(PREFIX\).*$|\1 = $PKG/usr|" Makefile
sed -i "s|^\(MANDIR\).*$|\1 = $PKG/usr/man|" Makefile
if [ "$STATIC" = "yes" ] ; then
- make static
+ make -j1 static
else
- make
+ make -j1
fi
make install