summaryrefslogtreecommitdiffstats
path: root/network/scapy
diff options
context:
space:
mode:
Diffstat (limited to 'network/scapy')
-rw-r--r--network/scapy/scapy.SlackBuild13
-rw-r--r--network/scapy/scapy.info6
2 files changed, 12 insertions, 7 deletions
diff --git a/network/scapy/scapy.SlackBuild b/network/scapy/scapy.SlackBuild
index 6acad51ad6..44a2db956e 100644
--- a/network/scapy/scapy.SlackBuild
+++ b/network/scapy/scapy.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for scapy (http://www.secdev.org/projects/scapy/)
#
-# Copyright 2008-2022 Corrado Franco (http://conraid.net)
+# Copyright 2008-2023 Corrado Franco (http://conraid.net)
# All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=scapy
-VERSION=${VERSION:-2.4.5}
+VERSION=${VERSION:-2.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -68,8 +68,13 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed "s|share/man/man1|man/man1|g" -i setup.py
-python setup.py build
-python setup.py install --root=$PKG
+python2 setup.py build
+python2 setup.py install --root=$PKG
+
+if [ -d $PKG/usr/man ]; then
+ find $PKG/usr/man -type f -exec chmod 644 {} \; -exec gzip -9 {} \;
+ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/network/scapy/scapy.info b/network/scapy/scapy.info
index 75a68107d3..417e962fca 100644
--- a/network/scapy/scapy.info
+++ b/network/scapy/scapy.info
@@ -1,8 +1,8 @@
PRGNAM="scapy"
-VERSION="2.4.5"
+VERSION="2.5.0"
HOMEPAGE="http://www.secdev.org/projects/scapy/"
-DOWNLOAD="https://github.com/secdev/scapy/archive/v2.4.5/scapy-2.4.5.tar.gz"
-MD5SUM="fdbb2c8d614bc3836a670e458cae6604"
+DOWNLOAD="https://github.com/secdev/scapy/archive/v2.5.0/scapy-2.5.0.tar.gz"
+MD5SUM="953cd03bde6fe31e361a83487d75dbcf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""