summaryrefslogtreecommitdiffstats
path: root/network/scapy/scapy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/scapy/scapy.SlackBuild')
-rw-r--r--network/scapy/scapy.SlackBuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/network/scapy/scapy.SlackBuild b/network/scapy/scapy.SlackBuild
index 6acad51ad6..44a2db956e 100644
--- a/network/scapy/scapy.SlackBuild
+++ b/network/scapy/scapy.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for scapy (http://www.secdev.org/projects/scapy/)
#
-# Copyright 2008-2022 Corrado Franco (http://conraid.net)
+# Copyright 2008-2023 Corrado Franco (http://conraid.net)
# All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=scapy
-VERSION=${VERSION:-2.4.5}
+VERSION=${VERSION:-2.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -68,8 +68,13 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed "s|share/man/man1|man/man1|g" -i setup.py
-python setup.py build
-python setup.py install --root=$PKG
+python2 setup.py build
+python2 setup.py install --root=$PKG
+
+if [ -d $PKG/usr/man ]; then
+ find $PKG/usr/man -type f -exec chmod 644 {} \; -exec gzip -9 {} \;
+ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild