summaryrefslogtreecommitdiffstats
path: root/network/prosody
diff options
context:
space:
mode:
Diffstat (limited to 'network/prosody')
-rw-r--r--network/prosody/README9
-rw-r--r--network/prosody/README.SBo1
-rw-r--r--network/prosody/doinst.sh1
-rw-r--r--network/prosody/prosody.SlackBuild6
-rw-r--r--network/prosody/prosody.info6
-rw-r--r--network/prosody/slack-desc1
6 files changed, 17 insertions, 7 deletions
diff --git a/network/prosody/README b/network/prosody/README
index a288d0a37a..ca9434d31b 100644
--- a/network/prosody/README
+++ b/network/prosody/README
@@ -13,3 +13,12 @@ Something like this will suffice for most systems:
Feel free to use a different uid and gid if desired, but 274 is
recommended to avoid conflicts with other stuff from SlackBuilds.org.
+
+Optional dependencies:
+
+* luaevent - Efficiently scale above hundreds of concurrent connections
+* lua-zlib - Compressing XMPP streams when mod_compression is enabled
+* luadbi - SQL database support (SQLite3, MySQL, PostgreSQL)
+* LuaBitOp - Efficient bit-level manipulation (used by mod_websocket)
+
+All optional dependencies are available at SBo.
diff --git a/network/prosody/README.SBo b/network/prosody/README.SBo
index af7fc668d0..83f036f35e 100644
--- a/network/prosody/README.SBo
+++ b/network/prosody/README.SBo
@@ -14,3 +14,4 @@ make sure rc.local and rc.local_shutdown contain the following lines:
if [ -x /etc/rc.d/rc.prosody ]; then
/etc/rc.d/rc.prosody stop
fi
+
diff --git a/network/prosody/doinst.sh b/network/prosody/doinst.sh
index 93d6f240b8..04129d238b 100644
--- a/network/prosody/doinst.sh
+++ b/network/prosody/doinst.sh
@@ -16,7 +16,6 @@ config etc/prosody/certs/example.com.key.new
config etc/prosody/certs/example.com.crt.new
config etc/prosody/certs/Makefile.new
config etc/prosody/certs/localhost.cnf.new
-config etc/prosody/certs/example.com.cnf.new
config etc/prosody/certs/localhost.crt.new
if ! [ -L etc/rc.d/rc.prosody ] ;
diff --git a/network/prosody/prosody.SlackBuild b/network/prosody/prosody.SlackBuild
index 3797e0a06f..1a03ac8b9e 100644
--- a/network/prosody/prosody.SlackBuild
+++ b/network/prosody/prosody.SlackBuild
@@ -25,7 +25,7 @@
# Maintained by Gerardo Zamudio <gerardo.zamudio@linux.com>
PRGNAM=prosody
-VERSION=${VERSION:-0.9.12}
+VERSION=${VERSION:-0.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -85,7 +85,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
./configure \
--ostype=linux \
@@ -118,7 +118,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS INSTALL COPYING DEPENDS README HACKERS TODO doc/*.* tools/*.lua \
+cp -a AUTHORS CHANGES INSTALL COPYING DEPENDS README HACKERS TODO doc/*.* tools/*.lua \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/network/prosody/prosody.info b/network/prosody/prosody.info
index bfaca3f18b..8d5351c362 100644
--- a/network/prosody/prosody.info
+++ b/network/prosody/prosody.info
@@ -1,8 +1,8 @@
PRGNAM="prosody"
-VERSION="0.9.12"
+VERSION="0.10.0"
HOMEPAGE="http://prosody.im/"
-DOWNLOAD="https://prosody.im/downloads/source/prosody-0.9.12.tar.gz"
-MD5SUM="d743adea6cfbaacc3a24cc0c3928bb1b"
+DOWNLOAD="https://prosody.im/downloads/source/prosody-0.10.0.tar.gz"
+MD5SUM="0eebf7a18ce1fc7dd9954c94ebd85f54"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="luasec luasocket luaexpat lua-filesystem"
diff --git a/network/prosody/slack-desc b/network/prosody/slack-desc
index 8d7c083519..6cf3ec9263 100644
--- a/network/prosody/slack-desc
+++ b/network/prosody/slack-desc
@@ -17,3 +17,4 @@ prosody:
prosody: Prosody is licensed under the permissive MIT/X11 license.
prosody:
prosody:
+