summaryrefslogtreecommitdiffstats
path: root/network/postfix
diff options
context:
space:
mode:
Diffstat (limited to 'network/postfix')
-rw-r--r--network/postfix/README39
-rw-r--r--network/postfix/doinst.sh40
-rw-r--r--network/postfix/patches/postconf.diff31
-rw-r--r--network/postfix/postfix.SlackBuild199
-rw-r--r--network/postfix/postfix.info10
-rw-r--r--network/postfix/rc.postfix67
-rw-r--r--network/postfix/slack-desc19
7 files changed, 0 insertions, 405 deletions
diff --git a/network/postfix/README b/network/postfix/README
deleted file mode 100644
index 80840d5668..0000000000
--- a/network/postfix/README
+++ /dev/null
@@ -1,39 +0,0 @@
-Postfix is Wietse Venema's mailer that started life as an alternative to the
-widely-used Sendmail program. It attempts to be fast, easy to administer, and
-secure, while at the same time, being sendmail compatible enough to not upset
-existing users. Thus, the outside has a sendmail-ish flavor, but the inside is
-completely different.
-
-This script builds postfix with optional support for Dovecot SASL, Cyrus SASL
-can be enabled with:
-
- SASL=cyrus ./postfix.SlackBuild
-
-You can also enable support for MySQL:
-
- DATABASE=mysql ./postfix.SlackBuild
-
-PostgreSQL support can be enabled with:
-
- DATABASE=pgsql ./postfix.SlackBuild
-
-On systems with multiple instances, add major version, eg: DATABASE=pgsql-9.5
-
-This script will find support for BerkleyDB and PCRE automagically; TLS support
-requires openssl package, openssl-solibs alone is not enough. Additionally, this
-script doesn't add postfix user and groups, instead it offers sane defaults that
-won't conflict with system users and groups, and other scripts from the SBo.
-
-Package created with this script will conflict with stock sendmail package, you
-*should* remove sendmail before installing postfix, otherwise sendmail updates
-could break your postfix instance.
-
-When upgrading from an older postfix version, make sure the variables such as
-html_directory and readme_directory in /etc/postfix/main.cf point to the new
-location. These can also be fixed later, afterwards make sure to run:
-
- postfix set-permissions
-
-Furthermore, many of the utilities in postfix have multiple manpages such as
-postconf(5) and postconf(8). Use man -k to find them, and don't forget to
-subscribe to the postfix-users mailing list!
diff --git a/network/postfix/doinst.sh b/network/postfix/doinst.sh
deleted file mode 100644
index 97e6510432..0000000000
--- a/network/postfix/doinst.sh
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/bin/sh
-
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-preserve_perms() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- if [ -e $OLD ]; then
- cp -a $OLD ${NEW}.incoming
- cat $NEW > ${NEW}.incoming
- mv ${NEW}.incoming $NEW
- fi
- config $NEW
-}
-
-find etc/postfix -type f -name '*.new' \
- | while read new ; do config $new ; done
-
-preserve_perms etc/rc.d/rc.postfix.new
-
-# This is an incompatability with the sendmail package
-( cd usr/lib; rm -f sendmail )
-( cd usr/lib; ln -s /usr/sbin/sendmail sendmail)
-
-# This will set the permissions on all postfix files correctly
-postfix set-permissions
-
-# Symlinks added by makepkg(8)
-
diff --git a/network/postfix/patches/postconf.diff b/network/postfix/patches/postconf.diff
deleted file mode 100644
index c51c1822fe..0000000000
--- a/network/postfix/patches/postconf.diff
+++ /dev/null
@@ -1,31 +0,0 @@
---- postfix-3.0.3/postfix-install.orig 2015-01-29 23:15:30.000000000 +0100
-+++ postfix-3.0.3/postfix-install 2015-10-17 03:57:42.269896095 +0200
-@@ -248,7 +248,7 @@
- case "$junk" in
- *MAIL_VERSION*)
- case "$mail_version" in
-- "") mail_version="`bin/postconf -dhx mail_version`" || exit 1
-+ "") mail_version="`bin/postconf -c conf -dhx mail_version`" || exit 1
- esac
- val=`echo "$junk" | sed 's/MAIL_VERSION$/'"$mail_version/g"` || exit 1
- case "$val" in
-@@ -810,7 +810,7 @@
- # the wrong place when Postfix is being upgraded.
-
- case "$mail_version" in
--"") mail_version="`bin/postconf -dhx mail_version`" || exit 1
-+"") mail_version="`bin/postconf -c conf -dhx mail_version`" || exit 1
- esac
-
- # Undo MAIL_VERSION expansion at the end of a parameter value. If
---- postfix-3.0.3/Makefile.in.orig 2014-09-25 21:16:29.000000000 +0200
-+++ postfix-3.0.3/Makefile.in 2015-10-17 04:01:27.170920308 +0200
-@@ -20,7 +20,7 @@
- EXPAND = sed -e "s;\$${LIB_PREFIX};$(LIB_PREFIX);" \
- -e "s;\$${LIB_SUFFIX};$(LIB_SUFFIX);"
- SHLIB_DIR_OVERRIDE = \
-- $${shlib_directory:-`$(SHLIB_ENV) bin/postconf -dhx shlib_directory`}
-+ $${shlib_directory:-`$(SHLIB_ENV) bin/postconf -c conf -dhx shlib_directory`}
-
- default: update
-
diff --git a/network/postfix/postfix.SlackBuild b/network/postfix/postfix.SlackBuild
deleted file mode 100644
index 6bf3f38e2d..0000000000
--- a/network/postfix/postfix.SlackBuild
+++ /dev/null
@@ -1,199 +0,0 @@
-#!/bin/sh
-#
-# Copyright 2006, 2011 Alan Hicks, Lizella, GA
-# Copyright 2010, 2011, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Mario Preksavec, Zagreb, Croatia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=postfix
-VERSION=${VERSION:-3.3.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""5
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-# Build with dovecot sasl support by default
-SASL=${SASL:-dovecot}
-case "$SASL" in
- dovecot) SASLARGS="-DDEF_SERVER_SASL_TYPE=\\\"dovecot\\\""
- SASLLIBS="" ;;
- cyrus) SASLARGS="-I/usr/include/sasl -DUSE_CYRUS_SASL"
- SASLLIBS="-L/usr/lib${LIBDIRSUFFIX}/sasl2 -lsasl2" ;;
- *) SASLARGS=""
- SASLLIBS="" ;;
-esac
-
-# Build without database support by default
-DATABASE=${DATABASE:-none}
-case "$DATABASE" in
- mysql) DBARGS="-I/usr/include/mysql -DHAS_MYSQL"
- DBLIBS="-L/usr/lib${LIBDIRSUFFIX}/mysql -lmysqlclient -lz -lm" ;;
- pgsql*) PGVER=${DATABASE/pgsql-}
- [ "$PGVER" = "pgsql" ] && PGVER=$(ls /usr/lib${LIBDIRSUFFIX}/postgresql/)
- [ -d "/usr/lib${LIBDIRSUFFIX}/postgresql/$PGVER/lib" ] && {
- DBARGS="-I/usr/include/postgresql -DHAS_PGSQL"
- DBLIBS="-L/usr/lib${LIBDIRSUFFIX}/postgresql/$PGVER/lib -lpq -lz -lm"
- } || echo "PostgreSQL not found" ;;
- *) DBARGS=""
- DBLIBS="" ;;
-esac
-
-# Build without ldap support by default
-LDAP=${LDAP:-no}
-case "$LDAP" in
- yes) LDAPARGS="-DUSE_LDAP_SASL -DHAS_LDAP"
- LDAPLIBS="-lldap -llber" ;;
- *) LDAPARGS=""
- LDAPLIBS="" ;;
-esac
-
-# MySQL compile hack
-if [ $DATABASE == "mysql" ] && [ -f /usr/include/mysql/events.h ]; then
-
-cat << EOF
-
- Postfix will fail to compile with mysql support if a system-wide
- events.h file is not removed (postfix has its own events.h).
- Either disable mysql support or (re)move events.h, eg:
-
- # mv /usr/include/mysql/events.h /usr/include/mysql/events.h.bak
-
-EOF
-
- exit
-fi
-
-# Bail if user or group isn't valid on your system
-if ! grep ^postfix: /etc/passwd 2>&1 > /dev/null; then
-
-cat << EOF
-
- You must have a postfix user to run this script
-
- # groupadd -g 200 postfix
- # useradd -u 200 -d /dev/null -s /bin/false -g postfix postfix
-
-EOF
-
- exit
-elif ! grep ^postdrop: /etc/group 2>&1 > /dev/null; then
-
-cat << EOF
-
- You must have a postdrop group to run this script
-
- # groupadd -g 201 postdrop
-
-EOF
-
- exit
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Use config files from build tree, not system ones
-# This should probably go to upstream...
-patch -p1 <$CWD/patches/postconf.diff
-
-# Postfix does not use a ./configure script
-
-make makefiles shared=yes \
- CCARGS="-DUSE_SASL_AUTH -DUSE_TLS $SASLARGS $DBARGS $LDAPARGS" \
- AUXLIBS="-lssl -lcrypto $SASLLIBS $DBLIBS $LDAPLIBS" \
- OPT="$SLKCFLAGS" DEBUG=""
-
-make non-interactive-package \
- install_root=$PKG \
- tempdir=$TMP/$PRGNAM-temp \
- config_directory=/etc/postfix \
- daemon_directory=/usr/libexec/postfix \
- command_directory=/usr/sbin \
- queue_directory=/var/spool/postfix \
- sendmail_path=/usr/sbin/sendmail \
- newaliases_path=/usr/bin/newaliases \
- mailq_path=/usr/bin/mailq \
- mail_owner=postfix \
- setgid_group=postdrop \
- html_directory=/usr/doc/$PRGNAM-$VERSION/html \
- manpage_directory=/usr/man \
- readme_directory=/usr/doc/$PRGNAM-$VERSION/README_FILES
-
-install -D -m 0644 -oroot -groot $CWD/rc.postfix $PKG/etc/rc.d/rc.postfix.new
-find $PKG/etc/postfix -type f ! -name "*.default" ! -name "*.proto" ! -name "*.out" \
- ! -name "postfix-files" -exec mv {} {}.new \;
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-sed -i 's#\($manpage_directory/man[158]/.\+\.[158]\)\(:.*\)#\1.gz\2#' \
- $PKG/etc/postfix/postfix-files
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AAAREADME COMPATIBILITY COPYRIGHT HISTORY IPv6-ChangeLog LICENSE PORTING \
- RELEASE_NOTES TLS_ACKNOWLEDGEMENTS TLS_CHANGES TLS_LICENSE US_PATENT_6321267 \
- examples implementation-notes $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/postfix/postfix.info b/network/postfix/postfix.info
deleted file mode 100644
index 9809f40eb0..0000000000
--- a/network/postfix/postfix.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="postfix"
-VERSION="3.3.2"
-HOMEPAGE="http://www.postfix.org/"
-DOWNLOAD="http://cdn.postfix.johnriley.me/mirrors/postfix-release/official/postfix-3.3.2.tar.gz"
-MD5SUM="4e6ed7056576e0c54cfce6040a0bb0ad"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Mario Preksavec"
-EMAIL="mario at slackware dot hr"
diff --git a/network/postfix/rc.postfix b/network/postfix/rc.postfix
deleted file mode 100644
index 6e133ad9ec..0000000000
--- a/network/postfix/rc.postfix
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/bash
-# Copyright 2006, Alan Hicks, Lizella, GA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-
-postfix_start()
-{
- /usr/sbin/postfix start
-}
-
-postfix_stop()
-{
- /usr/sbin/postfix stop
-}
-
-postfix_restart()
-{
- postfix_stop
- postfix_start
-}
-
-postfix_reload()
-{
- /usr/sbin/postfix reload
-}
-
-postfix_status()
-{
- /usr/sbin/postfix status
-}
-
-case $1 in
-'start')
- postfix_start
- ;;
-'stop')
- postfix_stop
- ;;
-'restart')
- postfix_restart
- ;;
-'reload')
- postfix_reload
- ;;
-'status')
- postfix_status
- ;;
-*)
- echo "usage $0 start|stop|restart|reload|status"
-esac
diff --git a/network/postfix/slack-desc b/network/postfix/slack-desc
deleted file mode 100644
index 0e8c796afc..0000000000
--- a/network/postfix/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-postfix: postfix (alternative to the widely-used Sendmail program)
-postfix:
-postfix: Postfix attempts to be fast, easy to administer, and secure, while at
-postfix: the same time being sendmail compatible enough to not upset existing
-postfix: users. Thus, the outside has a sendmail-ish flavor, but the inside is
-postfix: completely different.
-postfix:
-postfix: Packaging script written by Alan Hicks <alan@lizella.net>
-postfix: and the SlackBuilds.org Team <http://www.slackbuilds.org>
-postfix:
-postfix: