summaryrefslogtreecommitdiffstats
path: root/network/mumble-server/mumble-server.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/mumble-server/mumble-server.SlackBuild')
-rw-r--r--network/mumble-server/mumble-server.SlackBuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/network/mumble-server/mumble-server.SlackBuild b/network/mumble-server/mumble-server.SlackBuild
index c5a2589751..5d4e1ad82a 100644
--- a/network/mumble-server/mumble-server.SlackBuild
+++ b/network/mumble-server/mumble-server.SlackBuild
@@ -27,10 +27,11 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mumble-server
SRCNAM=mumble
-VERSION=${VERSION:-1.4.230}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.4.287}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+ICE=${ICE:-no}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,6 +68,12 @@ if ! getent passwd $MURMUR_USER; then
exit 1
fi
+if [ "$ICE" = "no" ]; then
+ BUILD_ICE="-Dice=OFF"
+else
+ BUILD_ICE="-Dice=ON"
+fi
+
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
@@ -100,6 +104,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+sed -e "s|CMAKE_CXX_STANDARD 14|CMAKE_CXX_STANDARD 17|" -i CMakeLists.txt
mkdir -p build
(cd build
@@ -111,7 +116,7 @@ cmake \
-DCMAKE_BUILD_TYPE=Release \
-Dclient=OFF \
-Dserver=ON \
- -Dice=OFF \
+ $BUILD_ICE \
-Dzeroconf=OFF ..
make