summaryrefslogtreecommitdiffstats
path: root/network/etherpoke/etherpoke.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/etherpoke/etherpoke.SlackBuild')
-rw-r--r--network/etherpoke/etherpoke.SlackBuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/network/etherpoke/etherpoke.SlackBuild b/network/etherpoke/etherpoke.SlackBuild
index f60df039a9..65e459a5f4 100644
--- a/network/etherpoke/etherpoke.SlackBuild
+++ b/network/etherpoke/etherpoke.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for etherpoke
-# Copyright 2015-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2023 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=etherpoke
VERSION=${VERSION:-2.5.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,7 +70,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -82,13 +82,18 @@ find -L . \
mkdir -p $PKG/usr/sbin
sed -i "s#/usr/local/sbin#$PKG/usr/sbin#" src/Makefile
+sed -i '1d' README.md
+sed -i '1i Homepage: http://web.archive.org/web/20160305135410/http://codeward.org/etherpoke/' \
+ README.md
+
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md Changelog AUTHORS COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md Changelog AUTHORS COPYING conf/$PRGNAM.conf.example \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install