summaryrefslogtreecommitdiffstats
path: root/multimedia/vlc
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/vlc')
-rw-r--r--multimedia/vlc/README10
-rw-r--r--multimedia/vlc/cache.patch (renamed from multimedia/vlc/patch_vlc_cache_gen.diff)12
-rw-r--r--multimedia/vlc/dvdnav.patch (renamed from multimedia/vlc/patch-dvdnav-503.diff)4
-rw-r--r--multimedia/vlc/dvdread.patch (renamed from multimedia/vlc/patch-dvdread-503.diff)4
-rw-r--r--multimedia/vlc/patch-opencv4.diff24
-rw-r--r--multimedia/vlc/projectM.patch (renamed from multimedia/vlc/patch-projectM-fontpath.diff)6
-rw-r--r--multimedia/vlc/slack-desc2
-rw-r--r--multimedia/vlc/vlc.SlackBuild73
-rw-r--r--multimedia/vlc/vlc.info10
9 files changed, 57 insertions, 88 deletions
diff --git a/multimedia/vlc/README b/multimedia/vlc/README
index a9aeeda526..b823fbc0f4 100644
--- a/multimedia/vlc/README
+++ b/multimedia/vlc/README
@@ -14,7 +14,8 @@ continue to build with a reduced feature set.
Support for Wayland is a special case. It is not supported by default
but can be enabled setting the WAYLAND environment variable to "yes"
-when running the SlackBuild e.g. WAYLAND=yes sh vlc.SlackBuild
+when running the SlackBuild e.g.
+ WAYLAND=yes sh vlc.SlackBuild
By default, the vlc runtime is not able to be run as root. This
security feature may be side stepped by building vlc with the RUNASROOT
@@ -26,9 +27,10 @@ multimedia/aom or libraries/dav1d packages is detected when vlc
is built. One of these is expected to become required in a future
release. Some versions of the automatically detected optional aom
package are incompatible with this version of vlc and in this case
-the build will fai. This can be avoided by setting the AOM environment
+the build will fail. This can be avoided by setting the AOM environment
variable to "no" e.g.
AOM=no sh vlc.SlackBuild
-Please advise the maintainer to suggest support for any further
-options.
+You may disable LUA support by setting the LUA environment variable.
+This will remove the lua dependency e.g.
+ LUA=no sh vlc.SlackBuild
diff --git a/multimedia/vlc/patch_vlc_cache_gen.diff b/multimedia/vlc/cache.patch
index 957e6e96df..4225d33ad4 100644
--- a/multimedia/vlc/patch_vlc_cache_gen.diff
+++ b/multimedia/vlc/cache.patch
@@ -1,6 +1,6 @@
---- bin/Makefile.am.orig 2015-06-03 10:49:51.266282736 +1000
-+++ bin/Makefile.am 2015-06-03 10:50:20.469282310 +1000
-@@ -72,6 +72,10 @@
+--- a/bin/Makefile.am 2015-06-03 10:49:51.266282736 +1000
++++ b/bin/Makefile.am 2015-06-03 10:50:20.469282310 +1000
+@@ -124,6 +124,10 @@
vlc_cache_gen_DEPENDENCIES = vlc_win32_rc.$(OBJEXT)
endif
@@ -11,9 +11,9 @@
#
# Plug-ins cache
#
---- configure.ac.orig 2015-06-03 10:53:22.299279657 +1000
-+++ configure.ac 2015-06-03 09:44:33.338339889 +1000
-@@ -762,6 +762,12 @@
+--- a/configure.ac 2015-06-03 10:53:22.299279657 +1000
++++ b/configure.ac 2015-06-03 09:44:33.338339889 +1000
+@@ -888,6 +888,12 @@
])
])
diff --git a/multimedia/vlc/patch-dvdnav-503.diff b/multimedia/vlc/dvdnav.patch
index 422fc53d03..e5ecc80d75 100644
--- a/multimedia/vlc/patch-dvdnav-503.diff
+++ b/multimedia/vlc/dvdnav.patch
@@ -1,5 +1,5 @@
---- modules/access/dvdnav.c.orig 2020-04-07 23:35:05.000000000 +1000
-+++ modules/access/dvdnav.c 2020-04-16 22:32:34.175000000 +1000
+--- a/modules/access/dvdnav.c 2020-04-07 23:35:05.000000000 +1000
++++ b/modules/access/dvdnav.c 2020-04-16 22:32:34.175000000 +1000
@@ -59,6 +59,10 @@
diff --git a/multimedia/vlc/patch-dvdread-503.diff b/multimedia/vlc/dvdread.patch
index 81523e6829..0f2912d7e0 100644
--- a/multimedia/vlc/patch-dvdread-503.diff
+++ b/multimedia/vlc/dvdread.patch
@@ -1,5 +1,5 @@
---- modules/access/dvdread.c.orig 2020-03-28 23:39:33.000000000 +1000
-+++ modules/access/dvdread.c 2020-04-16 22:10:43.065000000 +1000
+--- a/modules/access/dvdread.c 2020-03-28 23:39:33.000000000 +1000
++++ b/modules/access/dvdread.c 2020-04-16 22:10:43.065000000 +1000
@@ -55,6 +55,12 @@
#include <unistd.h>
diff --git a/multimedia/vlc/patch-opencv4.diff b/multimedia/vlc/patch-opencv4.diff
deleted file mode 100644
index da158371d7..0000000000
--- a/multimedia/vlc/patch-opencv4.diff
+++ /dev/null
@@ -1,24 +0,0 @@
---- configure.ac.prev 2019-03-10 13:15:05.033000000 +1000
-+++ configure.ac 2019-03-10 13:19:03.840000000 +1000
-@@ -1848,7 +1848,7 @@
- dnl
- dnl OpenCV wrapper and example filters
- dnl
--PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_example opencv_wrapper], [opencv > 2.0], (OpenCV (computer vision) filter), [auto])
-+PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_wrapper], [opencv4 > 4.0], (OpenCV (computer vision) filter), [auto])
-
-
- dnl
---- modules/video_filter/Makefile.am.orig 2017-11-25 01:29:18.000000000 +1000
-+++ modules/video_filter/Makefile.am 2019-03-12 14:21:25.417000000 +1000
-@@ -147,8 +147,8 @@
- libdeinterlace_plugin_la_LIBADD = libdeinterlace_common.la
- video_filter_LTLIBRARIES += libdeinterlace_plugin.la
-
--libopencv_wrapper_plugin_la_SOURCES = video_filter/opencv_wrapper.c
--libopencv_wrapper_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) $(OPENCV_CFLAGS)
-+libopencv_wrapper_plugin_la_SOURCES = video_filter/opencv_wrapper.cpp
-+libopencv_wrapper_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) $(OPENCV_CFLAGS) -fpermissive
- libopencv_wrapper_plugin_la_LIBADD = $(OPENCV_LIBS)
- libopencv_wrapper_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(video_filterdir)'
- video_filter_LTLIBRARIES += $(LTLIBopencv_wrapper)
diff --git a/multimedia/vlc/patch-projectM-fontpath.diff b/multimedia/vlc/projectM.patch
index 5c4726296c..0eafc24628 100644
--- a/multimedia/vlc/patch-projectM-fontpath.diff
+++ b/multimedia/vlc/projectM.patch
@@ -1,6 +1,6 @@
---- modules/visualization/projectm.cpp.orig 2013-09-13 01:18:34.000000000 +1000
-+++ modules/visualization/projectm.cpp 2014-09-04 14:53:21.510242036 +1000
-@@ -79,8 +79,8 @@
+--- a/modules/visualization/projectm.cpp 2013-09-13 01:18:34.000000000 +1000
++++ b/modules/visualization/projectm.cpp 2014-09-04 14:53:21.510242036 +1000
+@@ -82,8 +82,8 @@
# define FONT_PATH_MENU "C:\\WINDOWS\\Fonts\\arial.ttf"
# define PRESET_PATH NULL
#else
diff --git a/multimedia/vlc/slack-desc b/multimedia/vlc/slack-desc
index 4ff7f2d288..7ae947d4c2 100644
--- a/multimedia/vlc/slack-desc
+++ b/multimedia/vlc/slack-desc
@@ -15,5 +15,5 @@ vlc: video codecs and file formats as well as DVDs, VCDs, and various
vlc: streaming protocols. It is able to stream over networks and to
vlc: transcode multimedia files and save them into various formats.
vlc:
-vlc: homepage: http://www.videolan.org/vlc/
+vlc: homepage: http://www.videolan.org/vlc
vlc:
diff --git a/multimedia/vlc/vlc.SlackBuild b/multimedia/vlc/vlc.SlackBuild
index 0198eb68cd..15f5b8c261 100644
--- a/multimedia/vlc/vlc.SlackBuild
+++ b/multimedia/vlc/vlc.SlackBuild
@@ -8,6 +8,8 @@
# Copyright (c) 2007,2008,2009,2010,2011 Eric Hameleers, Eindhoven, Netherlands
# Copyright (c) 2014-2022 Christoph Willing, Brisbane, Australia
# Copyright (c) 2022 Bill Kirkpatrick, Bay City, Texas, USA
+# Copyright (c) 2023 Tim Dickson, Scotland
+# Copyright (c) 2024 Steven Voges <Oregon, USA>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification is
@@ -30,14 +32,21 @@
# POSSIBILITY OF SUCH DAMAGE.
# -----------------------------------------------------------------------------
+# 20221224 bkw: Modified by SlackBuilds.org, BUILD=4:
+# - libebml builds are OK now, get rid of "stop the build" code.
+# - don't install useless INSTALL and ABOUT-NLS in doc dir.
+
# 20220215 bkw: Modified by SlackBuilds.org:
# - stop the build if libebml is installed, since it will fail.
+# 20230224 tjd: updated for 3.0.18 added patch to disable libplacebo
+# thanks to bkw
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vlc
-VERSION=${VERSION:-3.0.17.3}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-3.0.20}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,9 +58,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -73,26 +79,6 @@ else
fi
SLKLDFLAGS="-lrt"
-DOCS="ABOUT-NLS AUTHORS COPYING INSTALL NEWS README THANKS"
-
-# 20220215 bkw: this compiles for a long time, then fails, if libebml is
-# installed. Better to fail immediately and let the user know how to fix it.
-if [ "${FORCE:-no}" != "yes" ] && pkg-config --exists libebml; then
- cat <<EOF
-**********************************************************
-* Conflicting package found: libebml *
-**********************************************************
-* This build is known to fail when libebml is installed. *
-* Run "removepkg libebml", then re-run this script. *
-* You can reinstall libebml after vlc finishes building. *
-**********************************************************
-
-If you want to try building vlc anyway, export FORCE=yes
-in the environment.
-EOF
- exit 1
-fi
-
set -e
rm -rf $PKG
@@ -104,10 +90,10 @@ cd $PRGNAM-$VERSION
sed -i '/DEPRECATED/s:^://:' modules/text_renderer/freetype/text_layout.c
-patch -p0 < $CWD/patch-dvdread-503.diff
-patch -p0 < $CWD/patch-dvdnav-503.diff
-patch -p0 < $CWD/patch-projectM-fontpath.diff
-patch -p0 < $CWD/patch_vlc_cache_gen.diff
+patch -p1 < $CWD/dvdread.patch
+patch -p1 < $CWD/dvdnav.patch
+patch -p1 < $CWD/projectM.patch
+patch -p1 < $CWD/cache.patch
# Don't enable wayland by default
wayland="--disable-wayland" ; [ "${WAYLAND:-no}" != "no" ] && wayland="--enable-wayland"
@@ -118,6 +104,9 @@ runasroot=""; [ "${RUNASROOT:-no}" != "no" ] && runasroot="--enable-run-as-root"
# Give the possibility to explicitly disable aom support
aom=""; [ "${AOM:-yes}" = "no" ] && aom="--disable-aom"
+# Allow to build without lua
+lua=""; [ "${LUA:-yes}" = "no" ] && lua="--disable-lua"
+
autoreconf -fiv
chown -R root:root .
@@ -140,33 +129,35 @@ LDFLAGS="$SLKLDFLAGS" \
--build=$ARCH-slackware-linux \
--enable-qt=5 \
--enable-merge-ffmpeg \
+ --disable-libplacebo \
--disable-upnp \
$wayland \
$runasroot \
$aom \
-
+ $lua
make
make DESTDIR=$PKG install
+install -D -m0644 extras/analyser/vlc.vim $PKG/usr/share/vim/vimfiles/syntax/vlc.vim
+
+rm -f $PKG/usr/lib*/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
mkdir -p $PKG/usr/man/man1
gzip -9c doc/vlc.1 > $PKG/usr/man/man1/vlc.1.gz
-
-install -D -m0644 extras/analyser/vlc.vim $PKG/usr/share/vim/vimfiles/syntax/vlc.vim
+find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+for i in $(find $PKG/usr/man -type l -name "*.?") ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING NEWS README THANKS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc -type f -exec chmod 644 {} \;
chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION/*
-find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
-for i in $(find $PKG/usr/man -type l -name "*.?") ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-rm -f $PKG/usr/lib*/*.la
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
###sbolint off
diff --git a/multimedia/vlc/vlc.info b/multimedia/vlc/vlc.info
index 7951ae1d65..92eb2e2fa9 100644
--- a/multimedia/vlc/vlc.info
+++ b/multimedia/vlc/vlc.info
@@ -1,10 +1,10 @@
PRGNAM="vlc"
-VERSION="3.0.17.3"
+VERSION="3.0.20"
HOMEPAGE="https://www.videolan.org/vlc/"
-DOWNLOAD="https://get.videolan.org/vlc/3.0.17.3/vlc-3.0.17.3.tar.xz"
-MD5SUM="82907be60cea14e1423dacd51a23cf62"
+DOWNLOAD="https://get.videolan.org/vlc/3.0.20/vlc-3.0.20.tar.xz"
+MD5SUM="e8337fcd2df92f3901dad091fb85f545"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libass libdc1394 libdvbpsi libmpeg2 lua portaudio twolame gsm libtar libkate faac libdca libshout avahi projectM jack libsidplay2 zvbi faad2 libavc1394 libmodplug musepack-tools vcdimager dirac gnome-vfs live555 rtmpdump libdvdcss schroedinger libminizip chromaprint x264 x265 libnfs protobuf3"
-MAINTAINER="Bill Kirkpatrick"
-EMAIL="bkirkp@gmail.com"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"