summaryrefslogtreecommitdiffstats
path: root/multimedia/vlc/cache.patch
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/vlc/cache.patch')
-rw-r--r--multimedia/vlc/cache.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/multimedia/vlc/cache.patch b/multimedia/vlc/cache.patch
new file mode 100644
index 0000000000..4225d33ad4
--- /dev/null
+++ b/multimedia/vlc/cache.patch
@@ -0,0 +1,28 @@
+--- a/bin/Makefile.am 2015-06-03 10:49:51.266282736 +1000
++++ b/bin/Makefile.am 2015-06-03 10:50:20.469282310 +1000
+@@ -124,6 +124,10 @@
+ vlc_cache_gen_DEPENDENCIES = vlc_win32_rc.$(OBJEXT)
+ endif
+
++if HAVE_GOBJECT
++vlc_cache_gen_LDADD += $(GOBJECT_LIBS)
++endif
++
+ #
+ # Plug-ins cache
+ #
+--- a/configure.ac 2015-06-03 10:53:22.299279657 +1000
++++ b/configure.ac 2015-06-03 09:44:33.338339889 +1000
+@@ -888,6 +888,12 @@
+ ])
+ ])
+
++dnl
++dnl Check for gobject
++dnl
++have_gobject="no"
++PKG_CHECK_MODULES([GOBJECT], [gobject-2.0], [ have_gobject="yes" ])
++AM_CONDITIONAL(HAVE_GOBJECT, [ test "${have_gobject}" = "yes" ])
+
+ dnl
+ dnl Check for zlib.h and -lz along with system -lminizip if available