summaryrefslogtreecommitdiffstats
path: root/multimedia/mozplugger/mozplugger.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/mozplugger/mozplugger.SlackBuild')
-rw-r--r--multimedia/mozplugger/mozplugger.SlackBuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/multimedia/mozplugger/mozplugger.SlackBuild b/multimedia/mozplugger/mozplugger.SlackBuild
index b1689222d3..ac0540c022 100644
--- a/multimedia/mozplugger/mozplugger.SlackBuild
+++ b/multimedia/mozplugger/mozplugger.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mozplugger
-# Copyright (c) jue 2009, Dhaby Xiloj <slack.dhabyx@gmail.com>
+# Copyright (c) 2009-2013, Dhaby Xiloj <slack.dhabyx@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -22,7 +22,7 @@
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mozplugger
-VERSION=${VERSION:-1.14.3}
+VERSION=${VERSION:-2.1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,14 +46,14 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -march=native -fPIC"
+ SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -63,12 +63,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# sigh --rworkman
+# updated for 2.1.4 version
patch -p1 < $CWD/Makefile.in.diff
./configure \
@@ -93,6 +94,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION